< Home

Example for Configuring Two-way Frame Delay Measurement in a VLAN

Networking Requirements

As networks continue to rapidly develop and applications become more and more diversified, various value-added services such as IPTV, video conferencing and VOIP are becoming more widely used. Link connectivity and network performance determine QoS on bearer networks. Therefore, performance monitoring is especially important for service transmission.

In Figure 1, CFM is configured between CEs. To provide high-quality video services, carriers need to monitor the two-way delay over mobile bearer links in real time, while monitoring link connectivity. Monitoring the two-way delay over mobile bearer links allows the carriers to respond quickly to video service quality deterioration.

Figure 1 Configuring Y.1731 in a VLAN

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure on-demand two-way frame delay measurement for the end-to-end link between the CEs to periodically collect statistics about the delay in frame transmission.

Procedure

  1. Configure VLANs.

    # Configure CE1.

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] vlan 2
    [CE1-vlan2] quit
    [CE1] interface gigabitethernet 0/0/1
    [CE1-GigabitEthernet0/0/1] port link-type trunk
    [CE1-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
    [CE1-GigabitEthernet0/0/1] quit

    # Configure CE2.

    <HUAWEI> system-view
    [HUAWEI] sysname CE2
    [CE2] vlan 2
    [CE2-vlan2] quit
    [CE2] interface gigabitethernet 0/0/1
    [CE2-GigabitEthernet0/0/1] port link-type trunk
    [CE2-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
    [CE2-GigabitEthernet0/0/1] quit

    # Configure PE1.

    <HUAWEI> system-view
    [HUAWEI] sysname PE1
    [PE1] vlan 2
    [PE1-vlan2] quit
    [PE1] interface gigabitethernet 0/0/1
    [PE1-GigabitEthernet0/0/1] port link-type trunk
    [PE1-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
    [PE1-GigabitEthernet0/0/1] quit
    [PE1] interface gigabitethernet 0/0/2
    [PE1-GigabitEthernet0/0/2] port link-type trunk
    [PE1-GigabitEthernet0/0/2] port trunk allow-pass vlan 2
    [PE1-GigabitEthernet0/0/2] quit

    # Configure PE2.

    <HUAWEI> system-view
    [HUAWEI] sysname PE2
    [PE2] vlan 2
    [PE2-vlan2] quit
    [PE2] interface gigabitethernet 0/0/1
    [PE2-GigabitEthernet0/0/1] port link-type trunk
    [PE2-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
    [PE2-GigabitEthernet0/0/1] quit
    [PE2] interface gigabitethernet 0/0/2
    [PE2-GigabitEthernet0/0/2] port link-type trunk
    [PE2-GigabitEthernet0/0/2] port trunk allow-pass vlan 2
    [PE2-GigabitEthernet0/0/2] quit

  2. Configure basic Ethernet CFM functions and specify the MEP type as outward.

    Configure basic Ethernet CFM functions on each CE. Specify CFM version as IEEE Standard 802.1ag-2007, create an MD named md3 and an MA named ma3, and bind the MA to the VLAN.

    # Configure CE1.

    [CE1] cfm enable
    [CE1] cfm version standard
    [CE1] cfm md md3
    [CE1-md-md3] ma ma3
    [CE1-md-md3-ma-ma3] map vlan 2
    [CE1-md-md3-ma-ma3] mep mep-id 3 interface gigabitethernet 0/0/1 outward
    [CE1-md-md3-ma-ma3] mep ccm-send mep-id 3 enable
    [CE1-md-md3-ma-ma3] remote-mep mep-id 4
    [CE1-md-md3-ma-ma3] remote-mep ccm-receive mep-id 4 enable
    [CE1-md-md3-ma-ma3] quit
    [CE1-md-md3] quit

    # Configure CE2.

    [CE2] cfm enable
    [CE2] cfm version standard
    [CE2] cfm md md3
    [CE2-md-md3] ma ma3
    [CE2-md-md3-ma-ma3] map vlan 2
    [CE2-md-md3-ma-ma3] mep mep-id 4 interface gigabitethernet 0/0/1 outward
    [CE2-md-md3-ma-ma3] mep ccm-send mep-id 4 enable
    [CE2-md-md3-ma-ma3] remote-mep mep-id 3
    [CE2-md-md3-ma-ma3] remote-mep ccm-receive mep-id 3 enable
    [CE2-md-md3-ma-ma3] quit
    [CE2-md-md3] quit

  3. Verify the CFM configuration.

    # Run the display cfm remote-mep command on CE1 and CE2. You can view MEP information.

    [CE1] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable        
    --------------------------------------------------
     MD Name            : md3
     Level              : 0
     MA Name            : ma3
     RMEP ID            : 4
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 4c1f-cc6b-c208
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up
    [CE2] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md3
     Level              : 0
     MA Name            : ma3
     RMEP ID            : 3
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0044-0141-5410
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up 

  4. Configure CE2 to receive DMM frames.

    # Configure CE2.

    [CE2] cfm md md3
    [CE2-md-md3] ma ma3
    [CE2-md-md3-ma-ma3] delay-measure two-way receive mep 4
    [CE2-md-md3-ma-ma3] quit
    [CE2-md-md3] quit

  5. Enable two-way frame delay measurement.

    # Configure CE1.

    [CE1] cfm md md3
    [CE1-md-md3] ma ma3
    [CE1-md-md3-ma-ma3] delay-measure two-way send mep 3 remote-mep 4 interval 1000 count 20
    [CE1-md-md3-ma-ma3] quit
    [CE1-md-md3] quit

  6. Verify the configuration.

    # After the configuration is complete, run the display y1731 statistic-type twoway-delay md md3 ma ma3 command. You can see the statistics about the two-way frame delay.

    [CE1] display y1731 statistic-type twoway-delay md md3 ma ma3
    Measurement Start Time : 2014-11-01 15:41:27
    Latest two-way delay statistics:                                                
    --------------------------------------------------------------------------------
    Index    Delay(usec)    Delay variation(usec)                                   
    --------------------------------------------------------------------------------
        1            442                        -                                        2            417                       25                                        3            435                       18                                        4            579                      144                                        5            429                      150                                        6            428                        1                                        7            432                        4                                        8            437                        5                                        9            439                        2                                       10            435                        4                                       11            585                      150                                       12            443                      142                                       13            441                        2                                       14            510                       69                                       15            456                       54                                       16            445                       11                                       17            435                       10                                       18            435                        0                                       19            451                       16                                       20            601                      150                                   
    --------------------------------------------------------------------------------
    Average delay(usec) :        463    Average delay variation(usec) :         50
    Maximum delay(usec) :        601    Maximum delay variation(usec) :        150
    Minimum delay(usec) :        417    Minimum delay variation(usec) :          0

Configuration Files

  • CE1 configuration file

    #
    
    sysname CE1
    #
    vlan batch 2
    #
    cfm enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 3 interface GigabitEthernet0/0/1 outward
      mep ccm-send mep-id 3 enable
      remote-mep mep-id 4
      remote-mep ccm-receive mep-id 4 enable
    #
    return
  • CE2 configuration file

    #
    
    sysname CE2
    #
    vlan batch 2
    #
    cfm enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 4 interface GigabitEthernet0/0/1 outward
      mep ccm-send mep-id 4 enable
      remote-mep mep-id 3
      remote-mep ccm-receive mep-id 3 enable
      delay-measure two-way receive mep 4
    #
    return
  • PE1 configuration file

    #                                                                               
    sysname PE1                                                                    
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    interface GigabitEthernet0/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet0/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    return   
  • PE2 configuration file

    #                                                                               
    sysname PE2                                                                    
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    interface GigabitEthernet0/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet0/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    return   
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >