< Home

Example for Configuring Dual-ended Frame Loss Measurement in a VLAN

This section provides an example showing how to configure dual-ended frame loss measurement in VLAN networking.

Networking Requirements

With the increasing popularization and wide application of the Internet, various value-added services such as IPTV, video conferencing, and VoIP services are widely deployed. Link connectivity and network performance determine the Quality of Services (QoS) on bearer networks. Therefore, performance monitoring is especially important for service transmission channels.

As shown in Figure 1, CFM is configured between CEs. To provide high-quality audio services, providers hope to monitor the frame loss over mobile bearer links in real time, while monitoring link connectivity. Monitoring the frame loss over mobile bearer links allows the providers to respond quickly to video service quality deterioration.

Figure 1 Networking diagram for configuring Y.1731 function on a VLAN networking

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure VLAN information.

  2. Configure basic Ethernet CFM functions.

  3. Configure on-demand dual-ended frame loss measurement for the end-to-end link between the CEs to periodically collect statistics about the packet loss in frame transmission.

Procedure

  1. Configure VLANs.

    # Configure CE1.

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] vlan 2
    [CE1-vlan2] quit
    [CE1] interface gigabitethernet 0/0/1
    [CE1-GigabitEthernet0/0/1] port link-type trunk
    [CE1-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
    [CE1-GigabitEthernet0/0/1] quit
    

    # Configure CE2.

    <HUAWEI> system-view
    [HUAWEI] sysname CE2
    [CE2] vlan 2
    [CE2-vlan2] quit
    [CE2] interface gigabitethernet 0/0/1
    [CE2-GigabitEthernet0/0/1] port link-type trunk
    [CE2-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
    [CE2-GigabitEthernet0/0/1] quit

    # Configure PE1.

    <HUAWEI> system-view
    [HUAWEI] sysname PE1
    [PE1] vlan 2
    [PE1-vlan2] quit
    [PE1] interface gigabitethernet 0/0/1
    [PE1-GigabitEthernet0/0/1] port link-type trunk
    [PE1-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
    [PE1-GigabitEthernet0/0/1] quit
    [PE1] interface gigabitethernet 0/0/2
    [PE1-GigabitEthernet0/0/2] port link-type trunk
    [PE1-GigabitEthernet0/0/2] port trunk allow-pass vlan 2
    [PE1-GigabitEthernet0/0/2] quit

    # Configure PE2.

    <HUAWEI> system-view
    [HUAWEI] sysname PE2
    [PE2] vlan 2
    [PE2-vlan2] quit
    [PE2] interface gigabitethernet 0/0/1
    [PE2-GigabitEthernet0/0/1] port link-type trunk
    [PE2-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
    [PE2-GigabitEthernet0/0/1] quit
    [PE2] interface gigabitethernet 0/0/2
    [PE2-GigabitEthernet0/0/2] port link-type trunk
    [PE2-GigabitEthernet0/0/2] port trunk allow-pass vlan 2
    [PE2-GigabitEthernet0/0/2] quit

  2. Configure basic Ethernet CFM functions and specify the MEP type as outward.

    Configure basic Ethernet CFM functions on CE1 and CE2. Specify CFM version as IEEE Standard 802.1ag-2007. Create an MD named md3 and an MA named ma3, and bind the MA to the VLAN.

    # Configure CE1.

    [CE1] cfm enable
    [CE1] cfm version standard
    [CE1] cfm md md3
    [CE1-md-md3] ma ma3
    [CE1-md-md3-ma-ma3] map vlan 2
    [CE1-md-md3-ma-ma3] mep mep-id 3 interface gigabitethernet 0/0/1 outward
    [CE1-md-md3-ma-ma3] mep ccm-send mep-id 3 enable
    [CE1-md-md3-ma-ma3] remote-mep mep-id 4
    [CE1-md-md3-ma-ma3] remote-mep ccm-receive mep-id 4 enable
    [CE1-md-md3-ma-ma3] quit
    [CE1-md-md3] quit

    # Configure CE2.

    [CE2] cfm enable
    [CE2] cfm version standard
    [CE2] cfm md md3
    [CE2-md-md3] ma ma3
    [CE2-md-md3-ma-ma3] map vlan 2
    [CE2-md-md3-ma-ma3] mep mep-id 4 interface gigabitethernet 0/0/1 outward
    [CE2-md-md3-ma-ma3] mep ccm-send mep-id 4 enable
    [CE2-md-md3-ma-ma3] remote-mep mep-id 3
    [CE2-md-md3-ma-ma3] remote-mep ccm-receive mep-id 3 enable
    [CE2-md-md3-ma-ma3] quit
    [CE2-md-md3] quit

  3. Verify the CFM configuration.

    # Run the display cfm remote-mep command on CE1 and CE2. You can view MEP information.

    [CE1] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable        
    --------------------------------------------------
     MD Name            : md3
     Level              : 0
     MA Name            : ma3
     RMEP ID            : 4
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 4c1f-cc6b-c208
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up
    [CE2] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md3
     Level              : 0
     MA Name            : ma3
     RMEP ID            : 3
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0044-0141-5410
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up 

  4. Enable on-demand dual-ended frame loss measurement.

    # Configure CE1.

    [CE1] cfm md md3
    [CE1-md-md3] ma ma3
    [CE1-md-md3-ma-ma3] loss-measure dual-ended continual mep 3 remote-mep 4
    [CE1-md-md3-ma-ma3] quit
    [CE1-md-md3] quit

    # Configure CE2.

    [CE2] cfm md md3
    [CE2-md-md3] ma ma3
    [CE2-md-md3-ma-ma3] loss-measure dual-ended continual mep 4 remote-mep 3
    [CE2-md-md3-ma-ma3] quit
    [CE2-md-md3] quit

  5. Verify the configuration.

    # Run the display y1731 statistic-type dual-loss md md3 ma ma3 command on CE1. You can view the dual-ended frame loss statistics.
    [CE1] display y1731 statistic-type dual-loss md md3 ma ma3
    Measurement Start Time : 2018-09-28 16:48:39 
    Latest dual-ended loss statistics:
    --------------------------------------------------------------------------------
    Index    Local-loss    Local-loss ratio    Remote-loss    Remote-loss ratio
    --------------------------------------------------------------------------------
        1             0             0.0000%              0              0.0000%
        2             0             0.0000%              0              0.0000%
        3             5            50.0000%             10             50.0000%
        4             0             0.0000%              0              0.0000%
        5             5            50.0000%             10             50.0000%
        6            10            50.0000%              5             50.0000%
        7             5            50.0000%             10             50.0000%
        8            10            50.0000%              5             50.0000%
        9            10            50.0000%              5             50.0000%
       10             5            50.0000%             10             50.0000%
       11             5            50.0000%             10             50.0000%
       12            10            50.0000%              5             50.0000%
       13             5            50.0000%             10             50.0000%
       14            10            50.0000%              5             50.0000%
       15             5            50.0000%             10             50.0000%
       16            10            50.0000%              5             50.0000%
    --------------------------------------------------------------------------------
    Average Local-loss  :          5    Average Local-loss Ratio  :  40.6250%
    Maximum Local-loss  :         10    Maximum Local-loss Ratio  :  50.0000%
    Minimum Local-loss  :          0    Minimum Local-loss Ratio  :   0.0000%
    Average Remote-loss :          6    Average Remote-loss Ratio :  40.6250%
    Maximum Remote-loss :         10    Maximum Remote-loss Ratio :  50.0000%
    Minimum Remote-loss :          0    Minimum Remote-loss Ratio :   0.0000%
    

Configuration Files

  • Configuration file of CE1

    #
    sysname CE1
    #
    vlan batch 2
    #
    cfm enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 3 interface GigabitEthernet0/0/1 outward
      mep ccm-send mep-id 3 enable
      remote-mep mep-id 4
      remote-mep ccm-receive mep-id 4 enable
      loss-measure dual-ended continual mep 3 remote-mep 4
    #
    return
  • Configuration file of CE2

    #
    sysname CE2
    #
    vlan batch 2
    #
    cfm enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 4 interface GigabitEthernet0/0/1 outward
      mep ccm-send mep-id 4 enable
      remote-mep mep-id 3
      remote-mep ccm-receive mep-id 3 enable
      loss-measure dual-ended continual mep 4 remote-mep 3
    #
    return
  • Configuration file of PE1

    #                                                                               
    sysname PE1                                                                    
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    interface GigabitEthernet0/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet0/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    return   
  • Configuration file of PE2

    #                                                                               
    sysname PE2                                                                    
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    interface GigabitEthernet0/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet0/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    return   
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >