You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, WDS profile, and Mesh profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. Then the configuration is automatically delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.
As shown in Figure 1, an AC is connected to an AP through a switch on the network of a shopping mall.
The administrator expects to use the AP to scan BLE broadcast frames sent by BLE devices to obtain information about the BLE devices, such as universally unique identifiers (UUIDs) and received signal strength indicator (RSSI) calibration values, and report the information to the location server. When Bluetooth terminals of customers scan BLE devices and report obtained information about the BLE devices to the location server, the location server implements location algorithms for providing navigation services and pushing commodity sales information to customers through apps.
Item |
Data |
---|---|
Management VLAN for APs |
VLAN 100 |
Service VLAN for STAs |
VLAN 101 |
DHCP server |
The AC functions as the DHCP server for STAs and APs. |
IP address pool for APs |
10.23.100.2-10.23.100.254/24 |
IP address pool for STAs |
10.23.101.2-10.23.101.254/24 |
AC's source interface |
VLANIF 100 |
AP group |
|
Regulatory domain profile |
|
SSID profile |
|
Security profile |
|
VAP profile |
|
BLE profile |
|
The configuration roadmap is as follows:
Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.
In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.
Complete the location configuration on the location server. For details, see related documents of the location server.
# Configure access switch SwitchA. Add GE0/0/1 and GE0/0/2 on SwitchA to management VLAN 100.
<HUAWEI> system-view [HUAWEI] sysname SwitchA [SwitchA] vlan batch 100 [SwitchA] interface gigabitethernet 0/0/1 [SwitchA-GigabitEthernet0/0/1] port link-type trunk [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100 [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 [SwitchA-GigabitEthernet0/0/1] quit [SwitchA] interface gigabitethernet 0/0/2 [SwitchA-GigabitEthernet0/0/2] port link-type trunk [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 [SwitchA-GigabitEthernet0/0/2] quit
# Configure the AC. Add GE0/0/1 to VLAN 100.
<HUAWEI> system-view [HUAWEI] sysname AC [AC] vlan batch 100 101 [AC] interface gigabitethernet 0/0/1 [AC-GigabitEthernet0/0/1] port link-type trunk [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 [AC-GigabitEthernet0/0/1] quit
# Add GE0/0/2 of the AC for connecting to the location server to VLANs 100 and 101.
[AC] interface gigabitethernet 0/0/2 [AC-GigabitEthernet0/0/2] port link-type trunk [AC-GigabitEthernet0/0/2] port trunk pvid vlan 100 [AC-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101 [AC-GigabitEthernet0/0/2] quit
# Configure the AC as the DHCP server to allocate an IP address to the AP from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.
[AC] dhcp enable [AC] interface vlanif 100 [AC-Vlanif100] ip address 10.23.100.1 24 [AC-Vlanif100] dhcp select interface [AC-Vlanif100] quit [AC] interface vlanif 101 [AC-Vlanif101] ip address 10.23.101.1 24 [AC-Vlanif101] dhcp select interface [AC-Vlanif101] quit
[AC] wlan [AC-wlan-view] ap-group name ap-group1 [AC-wlan-ap-group-ap-group1] quit
[AC-wlan-view] regulatory-domain-profile name domain1 [AC-wlan-regulate-domain-domain1] country-code cn [AC-wlan-regulate-domain-domain1] quit [AC-wlan-view] ap-group name ap-group1 [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain1 Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continue?[Y/N]:y [AC-wlan-ap-group-ap-group1] quit [AC-wlan-view] quit
[AC] capwap source interface vlanif 100
By default, MAC address authentication is configured using the ap auth-mode command. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.
In this example, the AP4050DN-E is used and has two radios: radio 0 and radio 1.
[AC] wlan
[AC-wlan-view] ap auth-mode mac-auth
[AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
[AC-wlan-ap-0] ap-name area_1
[AC-wlan-ap-0] ap-group ap-group1
Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration s of the radio, Whether to continue? [Y/N]:y
# Power on the AP, and run the display ap all command to check the AP state. If the State field is displayed as nor, the AP is online.
[AC-wlan-view] display ap all Total AP information: nor : normal [1] ExtraInfo : Extra information P : insufficient power supply ------------------------------------------------------------------------------------- ID MAC Name Group IP Type State STA Uptime ------------------------------------------------------------------------------------- 0 60de-4476-e360 area_1 ap-group1 10.23.100.254 AP4050DN-E nor 0 25S ------------------------------------------------------------------------------------- Total: 1
In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.
[AC-wlan-view] security-profile name wlan-security [AC-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes [AC-wlan-sec-prof-wlan-security] quit
# Create SSID profile wlan-ssid and set the SSID name to wlan-net.
[AC-wlan-view] ssid-profile name wlan-ssid [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net [AC-wlan-ssid-prof-wlan-ssid] quit
# Create VAP profile wlan-vap, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.
[AC-wlan-view] vap-profile name wlan-vap [AC-wlan-vap-prof-wlan-vap] forward-mode tunnel [AC-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101 [AC-wlan-vap-prof-wlan-vap] security-profile wlan-security [AC-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid [AC-wlan-vap-prof-wlan-vap] quit
# Bind VAP profile wlan-vap to the AP group and apply the profile to radio 0 and radio 1 of the AP.
[AC-wlan-view] ap-group name ap-group1 [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio all [AC-wlan-ap-group-ap-group1] quit
[AC] wlan
[AC-wlan-view] ble-profile name wlan-ble
[AC-wlan-ble-prof-wlan-ble] sniffer enable ibeacon-mode
[AC-wlan-ble-prof-wlan-ble] report enable
[AC-wlan-ble-prof-wlan-ble] report-to-server ip-address 10.23.102.1 port 10001 via-ac ac-port 32180
[AC-wlan-ble-prof-wlan-ble] quit
[AC-wlan-view] ble monitoring-list mac 1234-1234-1000 to 1234-1234-1002
[AC-wlan-view] ap-group name ap-group1 [AC-wlan-ap-group-ap-group1] ble-profile wlan-ble [AC-wlan-ap-group-ap-group1] quit
The WLAN service configuration is automatically delivered to the AP. After the service configuration is complete, run the display vap ssid wlan-net command. If Status in the command output is displayed as ON, the VAPs have been successfully created on the AP radios.
[AC-wlan-view] display vap ssid wlan-net WID : WLAN ID ------------------------------------------------------------------------------------ AP ID AP name RfID WID BSSID Status Auth type STA SSID ------------------------------------------------------------------------------------ 0 area_1 0 1 60DE-4476-E360 ON WPA2-PSK 1 wlan-net 0 area_1 1 1 60DE-4476-E370 ON WPA2-PSK 0 wlan-net ------------------------------------------------------------------------------------ Total: 2
# After the AP obtains information about BLE devices, run the display wlan ble site-info { all | mac-address mac-address } command to view the information about BLE devices.
[AC-wlan-view] display wlan ble site-info all -------------------------------------------------------------------------------------------------------------------- Index MAC Host AP ID Host AP name RSSI Power Type DetachedFlag Aging-Timeout(m) Advertisement data -------------------------------------------------------------------------------------------------------------------- 1 1234-1234-1000 0 area_1 -80 80% ibeacon N 57 41-42-43-44-45-46-30-31-32-33-34-35-36-37-38-39-4d-41-4d-49-bf 2 1234-1234-1001 0 area_1 -85 60% ibeacon N 57 41-42-43-44-45-46-30-31-32-33-34-35-36-37-38-39-4d-41-4d-49-bf 3 1234-1234-1002 0 area_1 -83 60% ibeacon N 57 41-42-43-44-45-46-30-31-32-33-34-35-36-37-38-39-4d-41-4d-49-bf -------------------------------------------------------------------------------------------------------------------- Total: 3
After connecting to the WLAN of the shopping mall using a Bluetooth terminal enabled with the Bluetooth function, a user can use a location app to download the shopping mall's map and reports information about scanned BLE devices to the location server. The location server then implements location algorithms and sends the location of the Bluetooth terminal to the user. At the same time, the app server pushes commodity sales information to the user based on the location of the Bluetooth terminal.
SwitchA configuration file
# sysname SwitchA # vlan batch 100 # interface GigabitEthernet0/0/1 port link-type trunk port trunk pvid vlan 100 port trunk allow-pass vlan 100 # interface GigabitEthernet0/0/2 port link-type trunk port trunk allow-pass vlan 100 # return
AC configuration file
#
sysname AC
#
vlan batch 100 to 101
#
dhcp enable
#
interface Vlanif100
ip address 10.23.100.1 255.255.255.0
dhcp select interface
#
interface Vlanif101
ip address 10.23.101.1 255.255.255.0
dhcp select interface
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100 101
#
capwap source interface vlanif100
#
wlan
security-profile name wlan-security
security wpa2 psk pass-phrase %^%#_b"h2cpaO$9bZ-;`-_;CN5)k,_\UP3[!AJE6Vtg3%^%# aes
ssid-profile name wlan-ssid
ssid wlan-net
vap-profile name wlan-vap
forward-mode tunnel
service-vlan vlan-id 101
ssid-profile wlan-ssid
security-profile wlan-security
regulatory-domain-profile name domain1
ble-profile name wlan-ble
sniffer enable ibeacon-mode
report-to-server ip-address 10.23.102.1 port 10001 via-ac ac-port 32180
report enable
ble monitoring-list mac 1234-1234-1000
ble monitoring-list mac 1234-1234-1001
ble monitoring-list mac 1234-1234-1002
ap-group name ap-group1
ble-profile wlan-ble
regulatory-domain-profile domain1
radio 0
vap-profile wlan-vap wlan 1
radio 1
vap-profile wlan-vap wlan 1
ap-id 0 type-id 61 ap-mac 60de-4476-e360 ap-sn 210235419610CB002287
ap-name area_1
ap-group ap-group1
#
return