Example for Configuring One-Way Frame Delay Measurement in a VLAN

This example describes how to configure one-way frame delay measurement in a virtual local area network (VLAN) on an E2E network.

Networking Requirements

As networks continue to develop and diversify, various value-added services such as IPTV, video conferencing, and Voice over Internet Protocol (VoIP) are becoming increasingly popular. The performance monitoring function can be used to check the performance of links that transmit services.

On the network shown in Figure 1, CFM is configured to monitor the connectivity of links between customer edges (CEs). Because more users are demanding video services, the carrier also wants to implement one-way frame delay measurement as a response to video service quality deterioration.

Figure 1 Networking diagram for configuring Y.1731 function on a VLAN networking

Interfaces 1 and 2 in this example are GE 0/1/1, GE 0/1/2 respectively.


Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure on-demand one-way frame delay measurement for links between CEs.

  2. Configure proactive one-way frame delay measurement for links between CEs.

Data Preparation

To complete the configuration, you need the following data:

  • ID of a VLAN to which CE interfaces belong

  • Names of the MD and MA on CE1 and CE2

  • Interval between 1DM messages and number of detection times in on-demand OAM mode

Procedure

  1. Configure on-demand one-way frame delay measurement for links between CEs.

    1. Configure basic Ethernet CFM functions, including outward-facing MEPs.

      On each CE, configure IEEE Std 802.1ag-2007 CFM, create an MD named md3 and an MA named ma3, and bind the MA to a VLAN.

      # Configure CE1.

      <HUAWEI> system-view
      [~HUAWEI] sysname CE1
      [*HUAWEI] commit
      [~CE1] vlan 2
      [*CE1] interface gigabitethernet0/1/1
      [*CE1-GigabitEthernet0/1/1] portswitch
      [*CE1-GigabitEthernet0/1/1] port link-type trunk
      [*CE1-GigabitEthernet0/1/1] port trunk allow-pass vlan 2
      [*CE1-GigabitEthernet0/1/1] quit
      [*CE1] cfm enable
      [*CE1] cfm md md3
      [*CE1-md-md3] ma ma3
      [*CE1-md-md3-ma-ma3] map vlan 2
      [*CE1-md-md3-ma-ma3] mep mep-id 3 interface gigabitethernet0/1/1 outward
      [*CE1-md-md3-ma-ma3] mep ccm-send mep-id 3 enable
      [*CE1-md-md3-ma-ma3] remote-mep mep-id 4
      [*CE1-md-md3-ma-ma3] remote-mep ccm-receive mep-id 4 enable
      [*CE1-md-md3-ma-ma3] test-id 1 mep 3 remote-mep 4

      # Configure CE2.

      <HUAWEI> system-view
      [~HUAWEI] sysname CE2
      [*HUAWEI] commit
      [~CE2] vlan 2
      [*CE2] interface gigabitethernet0/1/1
      [*CE2-GigabitEthernet0/1/1]portswitch
      [*CE2-GigabitEthernet0/1/1]port link-type trunk
      [*CE2-GigabitEthernet0/1/1]port trunk allow-pass vlan 2
      [*CE2-GigabitEthernet0/1/1]quit
      [*CE2] cfm enable
      [*CE2] cfm md md3
      [*CE2-md-md3] ma ma3
      [*CE2-md-md3-ma-ma3] map vlan 2
      [*CE2-md-md3-ma-ma3] mep mep-id 4 interface gigabitethernet0/1/1 outward
      [*CE2-md-md3-ma-ma3] mep ccm-send mep-id 4 enable
      [*CE2-md-md3-ma-ma3] remote-mep mep-id 3
      [*CE2-md-md3-ma-ma3] remote-mep ccm-receive mep-id 3 enable
      [*CE2-md-md3-ma-ma3] test-id 1 mep 4
    2. Enable CE2 to receive 1DM messages.

      # Configure CE2.

      [*CE2] cfm md md3
      [*CE2-md-md3] ma ma3
      [*CE2-md-md3-ma-ma3] delay-measure one-way receive test-id 1
      [*CE2-md-md3-ma-ma3] quit
      [*CE2-md-md3] quit
      [*CE2] commit
    3. Enable on-demand one-way frame delay measurement.

      # Configure CE1.

      [~CE1] cfm md md3
      [*CE1-md-md3] ma ma3
      [*CE1-md-md3-ma-ma3] delay-measure one-way send test-id 1 interval 1000 count 20
      [*CE1-md-md3-ma-ma3] quit
      [*CE1-md-md3] quit
    4. Verify the configuration.

      # After completing the configuration, run the display y1731 statistic-type oneway-delay command to view actual on-demand one-way frame delay measurements on CE2.

      <HUAWEI> display y1731 statistic-type oneway-delay
      Latest one-way delay statistics of test-id 1:
      --------------------------------------------------------------------------------
      Index    Delay(usec)    Delay variation(usec)
      --------------------------------------------------------------------------------
          1            181                        -
          2            356                      175
          3            166                      190
          4            180                       14
          5            162                       18
          6            160                        2
          7            177                       17
          8            149                       28
          9            190                       41
         10            185                        5
         11            230                       45
         12            221                        9
         13            184                       37
         14            415                      231
         15            187                      228
         16            235                       48
         17            184                       51
         18            184                        0
         19            168                       16
         20            185                       17
      --------------------------------------------------------------------------------
      Average delay(usec) :         204    Average delay variation(usec) :         61
      Maximum delay(usec) :         415    Maximum delay variation(usec) :        231
      Minimum delay(usec) :         149    Minimum delay variation(usec) :          0
      
      

  2. Configure proactive one-way frame delay measurement for links between CEs.

    Proactive one-way frame delay measurement within a specified VLAN allows you to collect link measurement statistics continuously over a long term.

    1. Configure a test instance on CE2.

      # Configure CE2.

      [~CE2] cfm md md3
      [*CE2-md-md3] ma ma3
      [*CE2-md-md3-ma-ma3] test-id 2 mep 4 remote-mep 3
      [*CE2-md-md3-ma-ma3] quit
      [*CE2-md-md3] quit
      [*CE2] commit
    2. Enable CE1 to receive 1DM messages.

      # Configure CE1.

      [~CE1] cfm md md3
      [*CE1-md-md3] ma ma3
      [*CE1-md-md3] test-id 2 mep 3
      [*CE1-md-md3-ma-ma3] delay-measure one-way continual receive test-id 2
      [*CE1-md-md3-ma-ma3] quit
      [*CE1-md-md3] quit
      [*CE1] commit
    3. Enable proactive one-way frame delay measurement.

      # Configure CE2.

      [~CE2] cfm md md3
      [*CE2-md-md3] ma ma3
      [*CE2-md-md3-ma-ma3] delay-measure one-way continual send test-id 2 interval 1000
      [*CE2-md-md3-ma-ma3] quit
      [*CE2-md-md3] quit
      [*CE2] commit
    4. Verify the configuration.

      # After completing the configuration, run the display y1731 statistic-type oneway-delay command to view actual proactive one-way frame delay measurements on CE2.

      <HUAWEI> display y1731 statistic-type oneway-delay
      Latest one-way delay statistics of test-id 2:
      --------------------------------------------------------------------------------
      Index    Delay(usec)    Delay variation(usec)
      --------------------------------------------------------------------------------
          1            181                        -
          2            356                      175
          3            166                      190
          4            180                       14
          5            162                       18
          6            160                        2
          7            177                       17
          8            149                       28
          9            190                       41
         10            185                        5
         11            230                       45
         12            221                        9
         13            184                       37
         14            415                      231
         15            187                      228
         16            235                       48
         17            184                       51
         18            184                        0
         19            168                       16
         20            185                       17
      --------------------------------------------------------------------------------
      Average delay(usec) :         204    Average delay variation(usec) :         61
      Maximum delay(usec) :         415    Maximum delay variation(usec) :        231
      Minimum delay(usec) :         149    Minimum delay variation(usec) :          0
      
      

Configuration Files

  • CE1 configuration file

    #
    
     sysname CE1
    #
     vlan batch 2
    #
     cfm version standard
     cfm enable
    #
    interface GigabitEthernet0/1/1
     portswitch
     undo shutdown
     port trunk allow-pass vlan 2
    #
     cfm md md3
      ma ma3
       map vlan 2
       mep mep-id 3 interface GigabitEthernet0/1/1 outward
       mep ccm-send mep-id 3 enable
       remote-mep mep-id 4
       remote-mep ccm-receive mep-id 4 enable
       test-id 1 mep 3 remote-mep 4
       test-id 2 mep 3
       delay-measure one-way continual receive test-id 2
    #
    return
  • CE2 configuration file

    #
    
     sysname CE2
    #
     vlan 2
    #
     cfm version standard
     cfm enable
    #
    interface GigabitEthernet0/1/1
     portswitch
     undo shutdown
     port trunk allow-pass vlan 2
    #
     cfm md md3
      ma ma3
       map vlan 2
       mep mep-id 4 interface GigabitEthernet0/1/1 outward
       mep ccm-send mep-id 4 enable
       remote-mep mep-id 3
       remote-mep ccm-receive mep-id 3 enable
       test-id 1 mep 4
       delay-measure one-way receive test-id 1
       test-id 2 mep 4 remote-mep 3
       delay-measure one-way continual send test-id 2 interval 1000
    #
    return
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >