< Home

Example for Configuring a BGP4+ Route Reflector

Networking Requirements

As shown in Figure 1, four devices belong to two ASs. You are required to perform simplified configuration to ensure that the two ASs communicate with each other.

Figure 1 Networking diagram of configuring a BGP4+ route reflector

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic BGP4+ functions to allow BGP neighbors to communicate.

  2. Configure SwitchC as a route reflector so that no IBGP connection needs to be established between SwitchB and SwitchD. This simplifies the configuration.

Procedure

  1. Add interfaces to VLANs.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit
    

  2. Enable the IPv6 forwarding capability, and assign an IPv6 address for each interface.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA.

    [SwitchA] ipv6
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ipv6 enable
    [SwitchA-Vlanif10] ipv6 address fc00:0:0:0:1::1/64
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ipv6 enable
    [SwitchA-Vlanif20] ipv6 address fc00:0:0:0:10::1/96
    [SwitchA-Vlanif20] quit

  3. Configure basic BGP4+ functions.

    # Configure SwitchA.

    [SwitchA] bgp 100
    [SwitchA-bgp] router-id 10.1.1.1
    [SwitchA-bgp] peer fc00:0:0:0:10::2 as-number 200
    [SwitchA-bgp] ipv6-family unicast
    [SwitchA-bgp-af-ipv6] peer fc00:0:0:0:10::2 enable
    [SwitchA-bgp-af-ipv6] network fc00:0:0:0:1:: 64
    [SwitchA-bgp-af-ipv6] network fc00:0:0:0:10:: 96
    [SwitchA-bgp-af-ipv6] quit

    # Configure SwitchB.

    [SwitchB] bgp 200
    [SwitchB-bgp] router-id 10.2.2.2
    [SwitchB-bgp] peer fc00:0:0:0:10::1 as-number 100
    [SwitchB-bgp] peer fc00:0:0:0:11::1 as-number 200
    [SwitchB-bgp] ipv6-family unicast
    [SwitchB-bgp-af-ipv6] peer fc00:0:0:0:10::1 enable
    [SwitchB-bgp-af-ipv6] peer fc00:0:0:0:11::1 enable
    [SwitchB-bgp-af-ipv6] network fc00:0:0:0:10:: 96
    [SwitchB-bgp-af-ipv6] network fc00:0:0:0:11:: 96
    [SwitchB-bgp-af-ipv6] quit
    [SwitchB-bgp] quit

    # Configure SwitchC.

    [SwitchC] bgp 200
    [SwitchC-bgp] router-id 10.3.3.3
    [SwitchC-bgp] peer fc00:0:0:0:11::2 as-number 200
    [SwitchC-bgp] peer fc00:0:0:0:12::2 as-number 200
    [SwitchC-bgp] ipv6-family unicast
    [SwitchC-bgp-af-ipv6] peer fc00:0:0:0:11::2 enable
    [SwitchC-bgp-af-ipv6] peer fc00:0:0:0:12::2 enable
    [SwitchC-bgp-af-ipv6] network fc00:0:0:0:11:: 96
    [SwitchC-bgp-af-ipv6] network fc00:0:0:0:12:: 96
    [SwitchC-bgp-af-ipv6] quit

    # Configure SwitchD.

    [SwitchD] bgp 200
    [SwitchD-bgp] router-id 10.4.4.4
    [SwitchD-bgp] peer fc00:0:0:0:12::1 as-number 200
    [SwitchD-bgp] ipv6-family unicast
    [SwitchD-bgp-af-ipv6] peer fc00:0:0:0:12::1 enable
    [SwitchD-bgp-af-ipv6] network fc00:0:0:0:12:: 96
    [SwitchD-bgp-af-ipv6] quit
    [SwitchD-bgp] quit

  4. Configure the route reflector.

    # Configure SwitchC as the route reflector and SwitchB and SwitchD as the clients.

    [SwitchC-bgp] ipv6-family unicast
    [SwitchC-bgp-af-ipv6] peer fc00:0:0:0:11::2 reflect-client
    [SwitchC-bgp-af-ipv6] peer fc00:0:0:0:12::2 reflect-client

    # View the routing table of SwitchB.

    [SwitchB] display bgp ipv6 routing-table
    
     BGP Local router ID is 10.2.2.2
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
     Total Number of Routes: 6
     *>  Network  : 1::                                      PrefixLen : 64     
         NextHop  : FC00:0:0:0:10::1                         LocPrf    :          
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : 100  i
     *>  Network  : FC00:0:0:0:10::                          PrefixLen : 96     
         NextHop  : ::                                       LocPrf    :          
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
        
         NextHop  : FC00:0:0:0:10::1                         LocPrf    :          
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : 100  i
     *>  Network  : FC00:0:0:0:11::                          PrefixLen : 96     
         NextHop  : ::                                       LocPrf    :          
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
       i
         NextHop  : FC00:0:0:0:11::1                         LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
     *>i Network  : FC00:0:0:0:12::                          PrefixLen : 96     
         NextHop  : FC00:0:0:0:11::1                         LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i

    # View the routing table of SwitchD.

    [SwitchD] display bgp ipv6 routing-table
    
     BGP Local router ID is 10.4.4.4
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
     Total Number of Routes: 5
     *>i Network  : FC00:0:0:1::                             PrefixLen : 64     
         NextHop  : FC00:0:0:10::1                           LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : 100  i
     *>i Network  : FC00:0:0:10::                            PrefixLen : 96     
         NextHop  : FC00:0:0:11::2                           LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
     *>i Network  : FC00:0:0:11::                            PrefixLen : 96     
         NextHop  : FC00:0:0:12::1                           LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
     *>  Network  : FC00:0:0:12::                            PrefixLen : 96     
         NextHop  : ::                                       LocPrf    :          
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i
       i
         NextHop  : FC00:0:0:12::1                           LocPrf    : 100       
         MED      : 0                                        PrefVal   : 0         
         Label    : 
         Path/Ogn : i

    The routing tables show that SwitchD and SwitchB have learned the routing information advertised by SwitchA from SwitchC.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1::1/64
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:10::1/96
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bgp 100
     router-id 10.1.1.1
     peer FC00:0:0:10::2 as-number 200
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      network FC00:0:0:1:: 64
      network FC00:0:0:10:: 96
      peer FC00:0:0:10::2 enable
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 20 30
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:10::2/96
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:11::2/96
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bgp 200
     router-id 10.2.2.2
     peer FC00:0:0:10::1 as-number 100
     peer FC00:0:0:11::1 as-number 200
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      network FC00:0:0:10:: 96
      network FC00:0:0:11:: 96
      peer FC00:0:0:10::1 enable
      peer FC00:0:0:11::1 enable
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 30 40
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:11::1/96
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:12::1/96
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    bgp 200
     router-id 10.3.3.3
     peer FC00:0:0:11::2 as-number 200
     peer FC00:0:0:12::2 as-number 200
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      network FC00:0:0:11:: 96
      network FC00:0:0:12:: 96
      peer FC00:0:0:11::2 enable
      peer FC00:0:0:11::2 reflect-client
      peer FC00:0:0:12::2 enable
      peer FC00:0:0:12::2 reflect-client
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    ipv6
    #
    vlan batch 40
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:12::2/96
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    bgp 200
     router-id 10.4.4.4
     peer FC00:0:0:12::1 as-number 200
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      network FC00:0:0:12:: 96
      peer FC00:0:0:12::1 enable
    #
    return
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >