< Home

Example for Configuring an Inter-Chassis Eth-Trunk to Forward Traffic Preferentially Through Local Member Interfaces (Stack)

Networking Requirements

The S5720I-10X-PWH-SI-AC and S5720I-6X-PWH-SI-AC do not support this configuration.

On the network shown in Figure 1, Switch3 and Switch4 are connected through stack cables to increase the total switching capacity. The two switches are considered as one logical switch. To improve reliability, physical interfaces on the two switches are added to an Eth-Trunk. Traffic from two VLANs, VLAN 2 and VLAN 3, is forwarded through both the two interfaces GE1/0/1 and GE1/0/2 on the PE when the network runs properly. This provides high bandwidth use efficiency between devices and low traffic forwarding efficiency.

To improve traffic forwarding efficiency, each interface should only forward traffic from one VLAN (in this example, GE1/0/1 forwards traffic from VLAN 2 and GE1/0/2 forwards traffic from VLAN3). To achieve this goal, configure the Eth-Trunk to preferentially forward local traffic.

Figure 1 Preferentially forwarding traffic through the local member interface

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk.

  2. Add member interfaces to the Eth-Trunk.

  3. Configure the Eth-Trunk to preferentially forward local traffic.

  4. Configure the Layer 2 forwarding function.

Procedure

  1. Create an Eth-Trunk and configure the Eth-Trunk to allow packets from all VLANs to pass through.

    # Configure the stack.

    <HUAWEI> system-view
    [HUAWEI] sysname Stack
    [Stack] interface eth-trunk 10
    [Stack-Eth-Trunk10] port link-type trunk 
    [Stack-Eth-Trunk10] port trunk allow-pass vlan all
    [Stack-Eth-Trunk10] quit

    # Configure the PE.

    <HUAWEI> system-view
    [HUAWEI] sysname PE
    [PE] interface eth-trunk 10
    [PE-Eth-Trunk10] port link-type trunk
    [PE-Eth-Trunk10] port trunk allow-pass vlan all
    [PE-Eth-Trunk10] quit

  2. Add member interfaces to the Eth-Trunk.

    # Configure the stack.

    [Stack] interface gigabitethernet 1/0/4
    [Stack-GigabitEthernet1/0/4] eth-trunk 10
    [Stack-GigabitEthernet1/0/4] quit
    [Stack] interface gigabitethernet 2/0/4
    [Stack-GigabitEthernet2/0/4] eth-trunk 10
    [Stack-GigabitEthernet2/0/4] quit

    # Configure the PE.

    [PE] interface gigabitethernet 1/0/1
    [PE-GigabitEthernet1/0/1] eth-trunk 10
    [PE-GigabitEthernet1/0/1] quit
    [PE] interface gigabitethernet 1/0/2
    [PE-GigabitEthernet1/0/2] eth-trunk 10
    [PE-GigabitEthernet1/0/2] quit

  3. In the stack view, configure the Eth-Trunk to preferentially forward local traffic.

    On the S5735-L, S5735S-L, S5735S-L-M, S5735-S, S5735-S-I, and S5735S-S, run the following command:

    [Stack] local-preference enable

    On the devices except the S5735-L, S5735S-L, S5735S-L-M, S5735-S, S5735-S-I, and S5735S-S, run the following commands:

    [Stack] interface eth-trunk 10
    [Stack-Eth-Trunk10] local-preference enable
    [Stack-Eth-Trunk10] quit

  4. Configure the Layer 2 forwarding function.

    # Configure the stack.

    [Stack] vlan batch 2 3
    [Stack] interface gigabitethernet 1/0/3
    [Stack-GigabitEthernet1/0/3] port link-type trunk
    [Stack-GigabitEthernet1/0/3] port trunk allow-pass vlan 2
    [Stack-GigabitEthernet1/0/3] quit
    [Stack] interface gigabitethernet 2/0/3
    [Stack-GigabitEthernet2/0/3] port link-type trunk
    [Stack-GigabitEthernet2/0/3] port trunk allow-pass vlan 3
    [Stack-GigabitEthernet2/0/3] quit

    # Configure Switch1.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch1
    [Switch1] vlan 2
    [Switch1-vlan2] quit
    [Switch1] interface gigabitethernet 0/0/1
    [Switch1-GigabitEthernet0/0/1] port link-type trunk
    [Switch1-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
    [Switch1-GigabitEthernet0/0/1] quit
    [Switch1] interface gigabitethernet 0/0/2
    [Switch1-GigabitEthernet0/0/2] port link-type trunk
    [Switch1-GigabitEthernet0/0/2] port trunk allow-pass vlan 2
    [Switch1-GigabitEthernet0/0/2] quit

    # Configure Switch2.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch2
    [Switch2] vlan 3
    [Switch2-vlan3] quit
    [Switch2] interface gigabitethernet 0/0/1
    [Switch2-GigabitEthernet0/0/1] port link-type trunk
    [Switch2-GigabitEthernet0/0/1] port trunk allow-pass vlan 3
    [Switch2-GigabitEthernet0/0/1] quit
    [Switch2] interface gigabitethernet 0/0/2
    [Switch2-GigabitEthernet0/0/2] port link-type trunk
    [Switch2-GigabitEthernet0/0/2] port trunk allow-pass vlan 3
    [Switch2-GigabitEthernet0/0/2] quit

  5. Verify the configuration.

    Run the display trunkmembership eth-trunk command in any view to check information about Eth-Trunk member interfaces.

    The display on the stack is used as an example.

    <Stack> display trunkmembership eth-trunk 10
    Trunk ID: 10
    Used status: VALID
    TYPE: ethernet
    Working Mode : Normal
    Number Of Ports in Trunk = 2
    Number Of Up Ports in Trunk = 2
    Operate status: up
    
    Interface GigabitEthernet1/0/4, valid, operate up, weight=1
    Interface GigabitEthernet2/0/4, valid, operate up, weight=1

Configuration Files

  • Stack configuration file

    #
     sysname Stack
    #
     vlan batch 2 3
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    interface GigabitEthernet2/0/3
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    interface GigabitEthernet1/0/4
     eth-trunk 10
    #
    interface GigabitEthernet2/0/4
     eth-trunk 10
    #
    return         
  • PE configuration file

    #
     sysname PE
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet1/0/1
     eth-trunk 10
    #
    interface GigabitEthernet1/0/2
     eth-trunk 10
    #
    return
  • Switch1 configuration file

    #
     sysname Switch1
    #
     vlan batch 2
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    return
  • Switch2 configuration file

    #
     sysname Switch2
    #
     vlan batch 3
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    return
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic