< Home

Example for Configuring Basic IPv6 IS-IS Functions

Networking Requirements

In Figure 1, the four switches on the IPv6 network need to communicate with each other. SwitchA and SwitchB can only process a small amount of data.

Figure 1 Configuring basic IPv6 IS-IS functions

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IPv6 addresses on interfaces of each switch so that the switches can be interconnected.

  2. Enable IS-IS on each switch so that the switches can be interconnected. Configure SwitchA and SwitchB as Level-1 switches to enable them to maintain less data.

Procedure

  1. Configure VLANs that interfaces belong to.

    # Configure SwitchA. Ensure that the configurations of SwitchB, SwitchC, and SwitchD are the same as the configuration of SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit

  2. Enable the capability of IPv6 forwarding and configure IPv6 address for each interface.

    # Configure SwitchA. Ensure that the configurations of SwitchB, SwitchC, and SwitchD are the same as the configuration of SwitchA.

    [SwitchA] ipv6
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ipv6 enable
    [SwitchA-Vlanif10] ipv6 address fc00:0:0:10::2/64
    [SwitchA-Vlanif10] quit

  3. Configure IS-IS.

    # Configure SwitchA.

    [SwitchA] isis 1
    [SwitchA-isis-1] is-level level-1
    [SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [SwitchA-isis-1] ipv6 enable
    [SwitchA-isis-1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis ipv6 enable 1
    [SwitchA-Vlanif10] quit

    # Configure SwitchB.

    [SwitchB] isis 1 
    [SwitchB-isis-1] is-level level-1
    [SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchB-isis-1] ipv6 enable
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] isis ipv6 enable 1
    [SwitchB-Vlanif20] quit

    # Configure SwitchC.

    [SwitchC] isis 1
    [SwitchC-isis-1] network-entity 10.0000.0000.0003.00
    [SwitchC-isis-1] ipv6 enable
    [SwitchC-isis-1] quit
    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] isis ipv6 enable 1
    [SwitchC-Vlanif10] quit
    [SwitchC] interface vlanif 20
    [SwitchC-Vlanif20] isis ipv6 enable 1
    [SwitchC-Vlanif20] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] isis ipv6 enable 1
    [SwitchC-Vlanif30] isis circuit-level level-2
    [SwitchC-Vlanif30] quit

    # Configure SwitchD.

    [SwitchD] isis 1 
    [SwitchD-isis-1] is-level level-2
    [SwitchD-isis-1] network-entity 20.0000.0000.0004.00
    [SwitchD-isis-1] ipv6 enable
    [SwitchD-isis-1] quit
    [SwitchD] interface vlanif 30
    [SwitchD-Vlanif30] isis ipv6 enable 1
    [SwitchD-Vlanif30] quit
    [SwitchD] interface vlanif40
    [SwitchD-Vlanif40] isis ipv6 enable 1
    [SwitchD-Vlanif40] quit

  4. Verify the configuration.

    # Check the IS-IS routing table of SwitchA.

    [SwitchA] display isis route
    
                             Route information for ISIS(1)
                             -----------------------------
    
                            ISIS(1) Level-1 Forwarding Table
                            --------------------------------
    
    IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------------
    0.0.0.0/0            10         NULL   
    
     IPV6 Dest.      ExitInterface   NextHop                       Cost       Flags
    -------------------------------------------------------------------------------
     ::/0            Vlanif10        FE80::244:1FF:FE41:5411       10         A/-/-
     FC00:0:0:10::/64                            
                     Vlanif10        Direct                        10         D/L/-
     FC00:0:0:20::/64                            
                     Vlanif10        FE80::244:1FF:FE41:5411       20         A/-/-
    
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                   U-Up/Down Bit Set

    # Check the IS-IS neighbors of SwitchC.

    [SwitchC] display isis peer verbose
    
                              Peer information for ISIS(1)
    
      System Id     Interface          Circuit Id       State HoldTime Type     PRI
    -------------------------------------------------------------------------------
    0000.0000.0001  Vlanif10           0000.0000.0001.01 Up   8s       L1       64 
    
      MT IDs supported     : 0(UP) 
      Local MT IDs         : 0 
      Area Address(es)     : 10 
      Peer IPv6 Address(es): FE80::1234:FCFF:FEFC:199
      Uptime               : 00:02:08
      Adj Protocol         : IPV6 
      Restart Capable      : YES
      Suppressed Adj       : NO
      Peer System Id       : 0000.0000.0001  
    
    0000.0000.0002  Vlanif20           0000.0000.0003.02 Up   24s      L1       64 
    
      MT IDs supported     : 0(UP) 
      Local MT IDs         : 0 
      Area Address(es)     : 10 
      Peer IPv6 Address(es): FE80::225:9EFF:FEFB:494A
      Uptime               : 00:02:09
      Adj Protocol         : IPV6 
      Restart Capable      : YES
      Suppressed Adj       : NO
      Peer System Id       : 0000.0000.0002  
    
    0000.0000.0004  Vlanif30           0000.0000.0003.03 Up   27s      L2       64 
    
      MT IDs supported     : 0(UP) 
      Local MT IDs         : 0 
      Area Address(es)     : 20 
      Peer IPv6 Address(es): FE80::244:1FF:FE41:5410
      Uptime               : 00:02:16
      Adj Protocol         : IPV6 
      Restart Capable      : YES
      Suppressed Adj       : NO
      Peer System Id       : 0000.0000.0004  
    
    
    Total Peer(s): 3

    # Check the IS-IS LSDB of SwitchC.

    [SwitchC] display isis lsdb verbose
    
                            Database information for ISIS(1)
                            --------------------------------
    
                              Level-1 Link State Database
    
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00  0x00000005   0x3cb9        1009          86      0/0/0   
     SOURCE       0000.0000.0001.00
     NLPID        IPV6
     AREA ADDR    10 
     INTF ADDR V6 FC00:0:0:10::2                 
     Topology     Standard
     NBR  ID      0000.0000.0001.01  COST: 10        
     IPV6         FC00:0:0:10::/64                 COST: 10        
    
    0000.0000.0001.01-00  0x00000001   0xd8f1        1009          55      0/0/0   
     SOURCE       0000.0000.0001.01
     NLPID        IPV6
     NBR  ID      0000.0000.0001.00  COST: 0         
     NBR  ID      0000.0000.0003.00  COST: 0         
    
    0000.0000.0002.00-00  0x00000005   0x864b        1007          86      0/0/0   
     SOURCE       0000.0000.0002.00
     NLPID        IPV6
     AREA ADDR    10 
     INTF ADDR V6 FC00:0:0:20::2                 
     Topology     Standard
     NBR  ID      0000.0000.0003.02  COST: 10        
     IPV6         FC00:0:0:20::/64                 COST: 10        
    
    0000.0000.0003.00-00* 0x00000007   0xcf9b        1012          143     1/0/0   
     SOURCE       0000.0000.0003.00
     NLPID        IPV6
     AREA ADDR    10 
     INTF ADDR V6 FC00:0:0:10::1                 
     INTF ADDR V6 FC00:0:0:20::1                 
     INTF ADDR V6 FC00:0:0:30::1                 
     Topology     Standard
     NBR  ID      0000.0000.0001.01  COST: 10        
     NBR  ID      0000.0000.0003.02  COST: 10        
     IPV6         FC00:0:0:10::/64                 COST: 10        
     IPV6         FC00:0:0:20::/64                 COST: 10        
    
    0000.0000.0003.02-00* 0x00000001   0xc9fa        1009          55      0/0/0   
     SOURCE       0000.0000.0003.02
     NLPID        IPV6
     NBR  ID      0000.0000.0003.00  COST: 0         
     NBR  ID      0000.0000.0002.00  COST: 0         
    
    Total LSP(s): 5
        *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended), 
               ATT-Attached, P-Partition, OL-Overload
    
    
                              Level-2 Link State Database
    
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0003.00-00* 0x00000006   0x8ff6        1014          146     0/0/0   
     SOURCE       0000.0000.0003.00
     NLPID        IPV6
     AREA ADDR    10 
     INTF ADDR V6 FC00:0:0:10::1                 
     INTF ADDR V6 FC00:0:0:20::1                 
     INTF ADDR V6 FC00:0:0:30::1                 
     Topology     Standard
     NBR  ID      0000.0000.0003.03  COST: 10        
     IPV6         FC00:0:0:10::/64                 COST: 10        
     IPV6         FC00:0:0:20::/64                 COST: 10        
     IPV6         FC00:0:0:30::/64                 COST: 10        
    
    0000.0000.0003.03-00* 0x00000001   0xfac6        1012          55      0/0/0   
     SOURCE       0000.0000.0003.03
     NLPID        IPV6
     NBR  ID      0000.0000.0003.00  COST: 0         
     NBR  ID      0000.0000.0004.00  COST: 0         
    
    0000.0000.0004.00-00  0x00000005   0x5943        1009          86      0/0/0   
     SOURCE       0000.0000.0004.00
     NLPID        IPV6
     AREA ADDR    20 
     INTF ADDR V6 FC00:0:0:30::2                 
     Topology     Standard
     NBR  ID      0000.0000.0003.03  COST: 10        
     IPV6         FC00:0:0:30::/64                 COST: 10        
    
    Total LSP(s): 3
        *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended), 
               ATT-Attached, P-Partition, OL-Overload

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 10
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0001.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:10::2/64
     isis ipv6 enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 20
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0002.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:20::2/64
     isis ipv6 enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 10 20 30
    #
    isis 1
     network-entity 10.0000.0000.0003.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:10::1/64
     isis ipv6 enable 1
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:20::1/64
     isis ipv6 enable 1
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:30::1/64
     isis ipv6 enable 1
     isis circuit-level level-2
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    ipv6
    #
    vlan batch 30 40
    #
    isis 1
     is-level level-2
     network-entity 20.0000.0000.0004.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:30::2/64
     isis ipv6 enable 1
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:25::1/64
     isis ipv6 enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
Next topic >