< Home

Example for Configuring a UDP Jitter Test Instance

Networking Requirements

In Figure 1, a UDP Jitter test needs to be performed to obtain the jitter time of transmitting a packet from SwitchA to SwitchC.

Figure 1 Networking diagram for configuring a jitter test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as an NQA client and configure SwitchC as an NQA server.

  2. Configure the monitoring service type and port number on the NQA server.

  3. Create a UDP Jitter test instance on the NQA client.

Procedure

  1. Configure an IP address for each interface and ensure reachable routes between switches.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2

    # Configure SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] vlan 110
    [SwitchB-vlan110] quit
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 10.1.1.2 24
    [SwitchB-Vlanif100] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchB-GigabitEthernet0/0/2] port hybrid pvid vlan 110
    [SwitchB-GigabitEthernet0/0/2] port hybrid untagged vlan 110
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface vlanif 110
    [SwitchB-Vlanif110] ip address 10.2.1.1 24
    [SwitchB-Vlanif110] quit
    

    # Configure SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan 110
    [SwitchC-vlan110] quit
    [SwitchC] interface gigabitethernet 0/0/1
    [SwitchC-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchC-GigabitEthernet0/0/1] port hybrid pvid vlan 110
    [SwitchC-GigabitEthernet0/0/1] port hybrid untagged vlan 110
    [SwitchC-GigabitEthernet0/0/1] quit
    [SwitchC] interface vlanif 110
    [SwitchC-Vlanif110] ip address 10.2.1.2 24
    [SwitchC-Vlanif110] quit
    [SwitchC] ip route-static 10.1.1.0 255.255.255.0 10.2.1.1

  2. Configure an NQA server on SwitchC.

    # Configure the monitoring IP address and UDP port number on the NQA server.

    [SwitchC] nqa-server udpecho 10.2.1.2 9000

  3. Configure SwitchA.

    # Enable the NQA client and create a UDP Jitter test instance.

    [SwitchA] nqa test-instance admin jitter
    [SwitchA-nqa-admin-jitter] test-type jitter
    [SwitchA-nqa-admin-jitter] destination-address ipv4 10.2.1.2
    [SwitchA-nqa-admin-jitter] destination-port 9000 

  4. Start the test instance.

    [SwitchA-nqa-admin-jitter] start now

  5. Check the configuration.

    [SwitchA-nqa-admin-jitter] display nqa results test-instance admin jitter
     NQA entry(admin, jitter) :testflag is inactive ,testtype is jitter
      1 . Test 1 result   The test is finished                                      
       SendProbe:60                         ResponseProbe:60                        
       Completion:success                   RTD OverThresholds number:0             
       Min/Max/Avg/Sum RTT:1/80/6/331       RTT Square Sum:9341                     
       NumOfRTT:60                          Drop operation number:0                 
       Operation sequence errors number:0   RTT Stats errors number:0               
       System busy operation number:0       Operation timeout number:0              
       Min Positive SD:10                   Min Positive DS:10                      
       Max Positive SD:40                   Max Positive DS:40                      
       Positive SD Number:10                Positive DS Number:6                    
       Positive SD Sum:130                  Positive DS Sum:100                     
       Positive SD Square Sum:2500          Positive DS Square Sum:2400             
       Min Negative SD:10                   Min Negative DS:10                      
       Max Negative SD:40                   Max Negative DS:30                      
       Negative SD Number:9                 Negative DS Number:7                    
       Negative SD Sum:130                  Negative DS Sum:100                     
       Negative SD Square Sum:2700          Negative DS Square Sum:1800             
       Min Delay SD:0                       Min Delay DS:0                          
       Avg Delay SD:2                       Avg Delay DS:2                          
       Max Delay SD:40                      Max Delay DS:39                         
       Packet Loss SD:0                     Packet Loss DS:0                        
       Packet Loss Unknown:0                Average of Jitter:14                    
       Average of Jitter SD:13              Average of Jitter DS:15                 
       Jitter out value:2.5940387           Jitter in value:2.1560009               
       NumberOfOWD:60                       OWD SD Sum:145                          
       OWD DS Sum:126                       TimeStamp unit: ms                      
       Packet Rewrite Number: 0             Packet Rewrite Ratio: 0%                
       Packet Disorder Number: 0            Packet Disorder Ratio: 0%               
       Fragment-disorder Number: 0          Fragment-disorder Ratio: 0% 
       Start time: 2014-09-01 10:47:57+08:00                                                                                            
       End time: 2014-09-01 10:48:01+08:00  

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin jitter
     test-type jitter
     destination-address ipv4 10.2.1.2
     destination-port 9000
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    nqa-server udpecho 10.2.1.2 9000
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >