< Home

Example for Configuring a Path Jitter Test

Networking Requirements

As shown in Figure 1, SwitchA functions as an NQA client to test the jitter on the network between SwitchA and SwitchC.

Figure 1 Networking diagram for configuring the path jitter test

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as an NQA client and configure a path jitter test instance on SwitchA.

  2. Configure SwitchC as an NQA server.

Procedure

  1. Configure an IP address for each interface and ensure reachable routes between switches.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2

    # Configure SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] vlan 110
    [SwitchB-vlan110] quit
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 10.1.1.2 24
    [SwitchB-Vlanif100] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchB-GigabitEthernet0/0/2] port hybrid pvid vlan 110
    [SwitchB-GigabitEthernet0/0/2] port hybrid untagged vlan 110
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface vlanif 110
    [SwitchB-Vlanif110] ip address 10.2.1.1 24
    [SwitchB-Vlanif110] quit
    

    # Configure SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan 110
    [SwitchC-vlan110] quit
    [SwitchC] interface gigabitethernet 0/0/1
    [SwitchC-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchC-GigabitEthernet0/0/1] port hybrid pvid vlan 110
    [SwitchC-GigabitEthernet0/0/1] port hybrid untagged vlan 110
    [SwitchC-GigabitEthernet0/0/1] quit
    [SwitchC] interface vlanif 110
    [SwitchC-Vlanif110] ip address 10.2.1.2 24
    [SwitchC-Vlanif110] quit
    [SwitchC] ip route-static 10.1.1.0 255.255.255.0 10.2.1.1

  2. Configure SwitchA.

    # Enable the NQA client and create a path jitter test instance.

    [SwitchA] nqa test-instance admin pathjitter
    [SwitchA-nqa-admin-pathjitter] test-type pathjitter
    [SwitchA-nqa-admin-pathjitter] destination-address ipv4 10.2.1.2

  3. Start the test instance.

    [SwitchA-nqa-admin-pathjitter] start now

  4. Verify the test result.

    # View the test result.

    [SwitchA-nqa-admin-pathjitter] display nqa results test-instance admin pathjitter
                                                                                                                                        
     NQA entry(admin, pathjitter) :testflag is inactive ,testtype is pathjitter                                                         
       Current Status:CLOSE                                                                                                             
      1 . Test 1 result   The test is finished                                                                                          
       Trace Completion Status:success                                                                                                  
       1 . Hop 1                                                                                                                        
       Destination ip address:10.1.1.2                                                                                                  
       Jitter Completion Status:success     Jitter Finish Status:finished                                                               
       SendProbe:60                         ResponseProbe:60                                                                            
       Min/Max/Avg/Sum RTT:1/4/2/128        RTT Square Sum:286                                                                          
       NumOfRTT:60                          Drop operation number:0                                                                     
       Operation sequence errors number:0   RTT Stats errors number:0                                                                   
       System busy operation number:0       Operation timeout number:0                                                                  
       Min Positive SD:1                    Min Positive DS:1                                                                           
       Max Positive SD:2                    Max Positive DS:2                                                                           
       Positive SD Number:17                Positive DS Number:15                                                                       
       Positive SD Sum:18                   Positive DS Sum:16                                                                          
       Positive SD Square Sum:20            Positive DS Square Sum:18                                                                   
       Min Negative SD:1                    Min Negative DS:1                                                                           
       Max Negative SD:1                    Max Negative DS:1                                                                           
       Negative SD Number:17                Negative DS Number:17                                                                       
       Negative SD Sum:17                   Negative DS Sum:17                                                                          
       Negative SD Square Sum:17            Negative DS Square Sum:17                                                                   
       Max Delay SD:2                       Max Delay DS:1                                                                              
       Average of Jitter:1                  NumberOfOWD:60                                                                              
       Average of Jitter SD:1               Average of Jitter DS:1                                                                      
       Jitter out value:0.4592443           Jitter in value:0.4454907                                                                   
       OWD SD Sum:61                        OWD DS Sum:7                                                                                
       Packet Loss Ratio:0%                 Packet Loss Count:0                                                                         
       2 . Hop 2                                                                                                                        
       Destination ip address:10.2.1.2                                                                                                  
       Jitter Completion Status:success     Jitter Finish Status:finished                                                               
       SendProbe:60                         ResponseProbe:60                                                                            
       Min/Max/Avg/Sum RTT:2/89/9/518       RTT Square Sum:19734                                                                        
       NumOfRTT:60                          Drop operation number:0                                                                     
       Operation sequence errors number:0   RTT Stats errors number:0                                                                   
       System busy operation number:0       Operation timeout number:0                                                                  
       Min Positive SD:1                    Min Positive DS:1                                                                           
       Max Positive SD:84                   Max Positive DS:2                                                                           
       Positive SD Number:11                Positive DS Number:3                                                                        
       Positive SD Sum:161                  Positive DS Sum:5                                                                           
       Positive SD Square Sum:8821          Positive DS Square Sum:9                                                                    
       Min Negative SD:1                    Min Negative DS:1                                                                           
       Max Negative SD:22                   Max Negative DS:1                                                                           
       Negative SD Number:13                Negative DS Number:3                                                                        
       Negative SD Sum:137                  Negative DS Sum:3                                                                           
       Negative SD Square Sum:2347          Negative DS Square Sum:3                                                                    
       Max Delay SD:44                      Max Delay DS:44                                                                             
       Average of Jitter:10                 NumberOfOWD:60                                                                              
       Average of Jitter SD:12              Average of Jitter DS:1                                                                      
       Jitter out value:2.8217764           Jitter in value:0.0976862                                                                   
       OWD SD Sum:234                       OWD DS Sum:224                                                                              
       Packet Loss Ratio:0%                 Packet Loss Count:0    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin pathjitter
     test-type pathjitter
     destination-address ipv4 10.2.1.2
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >