< Home

Example for Configuring Original Flow Statistics Exporting

NetStream Overview

NetStream is a technology that collects statistics on and analyzes service traffic on networks. NetStream facilitates accounting and network monitoring.

It has the following advantages:

  • NetStream collects statistics on multiple types of information in packets. It provides powerful statistics collection function and detailed statistical results.
  • NetStream can be deployed at a low cost. No dedicated device is required to collect traffic information and no device interface is occupied.

Original flow statistics are exported when the flow aging time expires. Statistics on every flow are exported to the NetStream server. The NetStream server obtains detailed statistics on every flow.

Configuration Notes

NetStream conflicts with IP Source Trail on modular switches, so do not configure them simultaneously.

For the applicable product models and versions of this example, see Applicable product models and versions.

Networking Requirements

As shown in Figure 1, Department 1 and Department 2 connect to the Internet through SwitchA. Network administrators want to monitor communication between the two departments and the Internet, and perform accounting for each department.

Figure 1 Networking diagram for configuring original flow statistics exporting

Configuration Roadmap

You can configure IPv4 original flow statistics exporting on GE1/0/1 of SwitchA. Configure SwitchA to collect statistics on incoming and outgoing traffic on the interface, and to send the statistics to the NetStream server for further analysis. In this way, you can monitor communication between the two departments and the Internet, and perform accounting for each department.

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces on SwitchA.
  2. Configure NetStream sampling.
  3. Configure NetStream flow aging.
  4. Configure original flow statistics exporting.
  5. Configure the version of exported packets.
  6. Enable NetStream flow statistics collection on GE1/0/1.

Procedure

  1. Configure IP addresses for interfaces on SwitchA according to Figure 1.

    # Configure IP addresses for interfaces on SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 200 300 400
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface vlanif 200
    [SwitchA-Vlanif200] ip address 10.1.2.1 24
    [SwitchA-Vlanif200] quit
    [SwitchA] interface vlanif 300
    [SwitchA-Vlanif300] ip address 10.1.3.1 24
    [SwitchA-Vlanif300] quit
    [SwitchA] interface vlanif 400
    [SwitchA-Vlanif400] ip address 10.1.4.1 24
    [SwitchA-Vlanif400] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100 
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 200 
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 300 
    [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 300
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/4] port hybrid pvid vlan 400 
    [SwitchA-GigabitEthernet1/0/4] port hybrid untagged vlan 400
    [SwitchA-GigabitEthernet1/0/4] quit

  2. Configure NetStream sampling.

    # Configure NetStream sampling on GE1/0/1, set the sampling ratio to 1200.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] ip netstream sampler fix-packets 1200 inbound
    [SwitchA-GigabitEthernet1/0/1] ip netstream sampler fix-packets 1200 outbound
    [SwitchA-GigabitEthernet1/0/1] quit

  3. Configure NetStream flow aging.

    # Set the inactive aging time to 100 seconds and enable FIN- and RST-based aging.

    [SwitchA] ip netstream timeout inactive 100
    [SwitchA] ip netstream tcp-flag enable

  4. Configure NetStream original flow statistics exporting.

    # Set the source IP address of the exported packets carrying original flow statistics to 10.1.2.1, destination IP address to 10.1.2.2, and destination port number to 6000.

    [SwitchA] ip netstream export source 10.1.2.1
    [SwitchA] ip netstream export host 10.1.2.2 6000

  5. Configure the version of exported packets.

    # Set the version of exported packets to V9.

    [SwitchA] ip netstream export version 9

  6. Enable NetStream flow statistics collection on GE1/0/1.

    # Enable NetStream flow statistics collection on GE1/0/1.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] ip netstream inbound
    [SwitchA-GigabitEthernet1/0/1] ip netstream outbound
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] quit

  7. Verify the configuration.

    # After the configuration is complete, the NetStream server can receive statistics packets from SwitchA. Run the display ip netstream statistics command on SwitchA to view NetStream flow statistics.

    <SwitchA> display ip netstream statistics slot 1
    ===== Netstream statistics: =====                                              
     Origin/Flexible ingress entries  : 35
     Origin/Flexible ingress packets  : 381920
     Origin/Flexible ingress octets   : 125269760
     Origin/Flexible egress entries   : 0
     Origin/Flexible egress packets   : 0
     Origin/Flexible egress octets    : 0  
     Origin/Flexible total entries    : 35
     Handle origin entries            : 35
     Handle As aggre entries          : 0                                           
     Handle ProtPort aggre entries    : 0                                           
     Handle SrcPrefix aggre entries   : 0                                           
     Handle DstPrefix aggre entries   : 0                                           
     Handle Prefix aggre entries      : 0                                           
     Handle AsTos aggre entries       : 0                                           
     Handle ProtPortTos aggre entries : 0                                           
     Handle SrcPreTos aggre entries   : 0                                           
     Handle DstPreTos aggre entries   : 0                                           
     Handle PreTos aggre entries      : 0  

Configuration Files

Configuration file of SwitchA

#                                                                               
sysname SwitchA 
#                                                                               
vlan batch 100 200 300 400 
# 
ip netstream timeout inactive 100
ip netstream export version 9
ip netstream export source 10.1.2.1
ip netstream export host 10.1.2.2 6000
#
ip netstream tcp-flag enable
#                                                                               
interface Vlanif100                                                             
 ip address 10.1.1.1 255.255.255.0 
#                                                                               
interface Vlanif200                                                             
 ip address 10.1.2.1 255.255.255.0 
#                                                                               
interface Vlanif300                                                             
 ip address 10.1.3.1 255.255.255.0 
#                                                                               
interface Vlanif400                                                             
 ip address 10.1.4.1 255.255.255.0 
#                                                                               
interface GigabitEthernet1/0/1                                                  
 port link-type hybrid
 port hybrid pvid vlan 100                                                      
 port hybrid untagged vlan 100  
 ip netstream inbound
 ip netstream outbound
 ip netstream sampler fix-packets 1200 inbound
 ip netstream sampler fix-packets 1200 outbound
#                                                                               
interface GigabitEthernet1/0/2                                                  
 port link-type hybrid
 port hybrid pvid vlan 200                                                      
 port hybrid untagged vlan 200  
#                                                                               
interface GigabitEthernet1/0/3                                                  
 port link-type hybrid
 port hybrid pvid vlan 300                                                      
 port hybrid untagged vlan 300  
#                                                                               
interface GigabitEthernet1/0/4                                                  
 port link-type hybrid
 port hybrid pvid vlan 400                                                      
 port hybrid untagged vlan 400  
#
return

Applicable product models and versions

Product

Product Model

Software Version

S5700

S5700-HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00SPC500&C01&C02)

S5710-EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5710-HI

V200R003C00, V200R005(C00&C02&C03)

S5720-HI

V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00, V200R019C00, V200R019C10

S5730-HI

V200R012C00, V200R013C00, V200R019C00, V200R019C10

S5731-H

V200R013C02, V200R019C00, V200R019C10

S5731-S, S5731S-S

V200R019C00, V200R019C10

S5731S-H

V200R019C00, V200R019C10

S5732-H

V200R019C00, V200R019C10

S7700

S7703, S7706, S7712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00, V200R013C02, V200R019C00, V200R019C10

S7703 PoE

V200R013C00, V200R019C00, V200R019C10

S7706 PoE

V200R013C00, V200R019C00, V200R019C10

S9700

S9703, S9706, S9712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00

S6700

S6720-HI

V200R012C00, V200R013C00, V200R019C00, V200R019C10

S6730-H

V200R013C02, V200R019C00, V200R019C10

S6730S-H

V200R019C10

S6730-S, S6730S-S

V200R019C00, V200R019C10

For S7700&S9700 series switches, NetStream is only supported by B series cards, E series cards (except ET1D2X48SEC0 card and EH1D2X48SEC0 card), and X series cards.

Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
Next topic >