Example for Configuring the Unicast UDP Encapsulation Mode for 1588v2 Packets to Implement Network-wide Clock Synchronization

1588v2 is used to transmit frequency signals and time signals from the BITS server, allowing network-wide clock synchronization on the wireless transport network and wireless access network. For the NodeBs that support only UDP encapsulation, NetEngine 8000 Fs can send UDP-encapsulated 1588v2 packets to these NodeBs.

Context

Networking Requirements

On the network shown in Figure 1, the transport network transmits wireless services between NodeBs, and all transport network nodes support 1588v2. Core nodes PE1 and PE2 receive time information from the BITS server. NodeB-2 supports SyncE, instead of 1588v2. Both NodeB-1 and NodeB-3 support 1588v2. PE1 and PE2 dynamically select the grandmaster clock. The grandmaster clock transmits 1588v2 time signals over the entire network. 1588v2-enabled NodeBs and PEs can also achieve time synchronization in addition to frequency synchronization.

Because all nodes on the transport network support 1588v2, they can be configured as BCs to transmit clock information. For NodeB-2 that does not support 1588v2, frequency information can be transmitted through the clock signals over an E1 line.

Figure 1 Configuring the unicast MAC encapsulation mode for 1588v2 packets to implement network-wide clock synchronization

The configurations in this example are performed on PE1, PE2, CE1, and CE2. HUAWEI NetEngine 8000 F Series can function as PE1, PE2, CE1.


Device Name

Interface Name

Interface IP Address

Interface MAC Address

PE1

GE 0/1/8

10.0.0.1/24

00e0-fc22-1111

PE1

GE 0/1/0

172.16.0.1/24

00e0-fc11-1111

PE2

GE 0/1/8

10.0.0.2/24

00e0-fc22-2222

PE2

GE 0/1/0

192.168.0.1/24

00e0-fc11-2222

CE1

GE 0/1/8

172.16.0.2/24

00e0-fc22-1111

CE1

GE 0/1/0

10.10.0.1/24

00e0-fc22-3333

CE2

GE 0/1/0

192.168.0.2/24

00e0-fc22-4444

CE2

GE 0/1/1

172.16.1.1/24

00e0-fc22-5555

NodeB-1

-

10.10.0.2/24

00e0-fc33-1111

NodeB-3

-

172.16.1.2/24

00e0-fc33-2222

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a routing protocol and ensure the communion between devices. In this example, OSPF is used.

  2. Connect PE1 and PE2 to BITS servers.

  3. Configure PE1, PE2, CE1, and CE2 as BCs.

  4. Configure the unicast UDP encapsulation mode for 1588v2 packets.

Data Preparation

To complete the configuration, you need the following data:

  • Delay measurement mechanism of 1588 links: PDelay

  • Value of the 1588v2 domain where clock devices reside

  • Interval at which Announce messages are sent and the number of times Announce message receiving times out

  • Interval at which Sync messages are sent

  • Interval at which PDelay messages are sent

Procedure

  1. Assign an IP address to each interface and configure OSPF. The configuration details are not provided here.
  2. Configure PE1 and PE2 to use clock interfaces to import BITS signals.
    1. Configure PE1 to import BITS1 signals from BITS-1, participate in dynamic 1588v2 clock source selection, and import 1588v2 time signals.

      [*PE1] ptp enable
      [*PE1] clock bits-type bits1 1pps input
      [*PE1] ptp clock-source bits1 on
      [*PE1] ptp clock-source bits1 priority1 2
      [*PE1] clock source ptp synchronization enable
      [*PE1] clock source ptp priority 1
      [*PE1] ptp source-switch ptsf enable
      [*PE1] commit

    2. Configure PE2 to import BITS1 signals from BITS-2, participate in dynamic 1588v2 clock source selection, and import 1588v2 time signals.

      [*PE2] ptp enable
      [*PE2] clock bits-type bits1 1pps input
      [*PE2] ptp clock-source bits1 on
      [*PE2] ptp clock-source bits1 priority1 1
      [*PE2] clock source ptp synchronization enable
      [*PE2] clock source ptp priority 1
      [*PE2] ptp source-switch ptsf enable
      [*PE2] commit

  3. Configure PE1, PE2, CE1, and CE2 as BCs.
    1. Enable 1588v2 and configure 1588v2 parameters on PE1.

      [*PE1] ptp enable
      [*PE1] ptp device-type bc
      [*PE1] ptp domain 1
      [*PE1] commit
      [~PE1] interface gigabitethernet 0/1/0
      [~PE1-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
      [*PE1-GigabitEthernet0/1/0] ptp enable
      [*PE1-GigabitEthernet0/1/0] ptp udp-egress source-ip 172.16.0.1 destination-ip 172.16.0.2
      [*PE1-GigabitEthernet0/1/0] ptp udp-egress destination-mac 00e0-fc22-1111
      [*PE1-GigabitEthernet0/1/0] commit
      [~PE1-GigabitEthernet0/1/0] quit
      [~PE1] interface gigabitethernet 0/1/8
      [~PE1-GigabitEthernet0/1/8] ptp delay-mechanism pdelay
      [*PE1-GigabitEthernet0/1/8] ptp enable
      [*PE1-GigabitEthernet0/1/8] ptp udp-egress source-ip 10.0.0.1 destination-ip 10.0.0.2
      [*PE1-GigabitEthernet0/1/8] ptp udp-egress destination-mac 00e0-fc22-2222
      [*PE1-GigabitEthernet0/1/8] commit
      [~PE1-GigabitEthernet0/1/8] quit

    2. Enable 1588v2 and configure 1588v2 parameters on PE2.

      [*PE2] ptp enable
      [*PE2] ptp device-type bc
      [*PE2] ptp domain 1
      [*PE2] commit
      [~PE2] interface gigabitethernet 0/1/0
      [~PE2-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
      [*PE2-GigabitEthernet0/1/0] ptp enable
      [*PE2-GigabitEthernet0/1/0] ptp udp-egress source-ip 192.168.0.1 destination-ip 192.168.0.2
      [*PE2-GigabitEthernet0/1/0] ptp udp-egress destination-mac 00e0-fc22-4444
      [*PE2-GigabitEthernet0/1/0] commit
      [~PE2-GigabitEthernet0/1/0] quit
      [~PE2] interface gigabitethernet 0/1/8
      [~PE2-GigabitEthernet0/1/8] ptp delay-mechanism pdelay
      [*PE2-GigabitEthernet0/1/8] ptp enable
      [*PE2-GigabitEthernet0/1/8] ptp udp-egress source-ip 10.0.0.2 destination-ip 10.0.0.1
      [*PE2-GigabitEthernet0/1/8] ptp udp-egress destination-mac 00e0-fc22-1111
      [*PE2-GigabitEthernet0/1/8] commit
      [~PE2-GigabitEthernet0/1/8] quit

    3. Enable 1588v2 and configure 1588v2 parameters on CE1.

      [*CE1] ptp enable
      [*CE1] ptp device-type bc
      [*CE1] ptp domain 1
      [*CE1] commit
      [~CE1] interface gigabitethernet 0/1/8
      [~CE1-GigabitEthernet0/1/8] ptp delay-mechanism pdelay
      [*CE1-GigabitEthernet0/1/8] ptp enable
      [*CE1-GigabitEthernet0/1/8] ptp udp-egress source-ip 172.16.0.2 destination-ip 172.16.0.1
      [*CE1-GigabitEthernet0/1/8] ptp udp-egress destination-mac 00e0-fc11-1111
      [*CE1-GigabitEthernet0/1/8] commit
      [~CE1-GigabitEthernet0/1/8] quit
      [~CE1] interface gigabitethernet 0/1/0
      [~CE1-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
      [*CE1-GigabitEthernet0/1/0] ptp enable
      [*CE1-GigabitEthernet0/1/0] ptp udp-egress source-ip 10.10.0.1 destination-ip 10.10.0.2
      [*CE1-GigabitEthernet0/1/0] ptp udp-egress destination-mac 00e0-fc33-1111
      [*CE1-GigabitEthernet0/1/0] commit
      [~CE1-GigabitEthernet0/1/0] quit

    4. Configure NodeB-1 to receive 1588v2 packets from CE1. The configuration details are not provided here.
    5. Enable 1588v2 and configure 1588v2 parameters on CE2. Specify 1588v2 time signals as the local primary clock reference source.

      [*CE2] ptp enable
      [*CE2] ptp device-type bc
      [*CE2] ptp domain 1
      [*CE2] clock manual source ptp
      [*CE2] commit
      [~CE2] interface gigabitethernet 0/1/0
      [~CE2-GigabitEthernet0/1/0] ptp delay-mechanism pdelay
      [*CE2-GigabitEthernet0/1/0] ptp enable
      [*CE2-GigabitEthernet0/1/0] ptp udp-egress source-ip 192.168.0.2 destination-ip 192.168.0.1
      [*CE2-GigabitEthernet0/1/0] ptp udp-egress destination-mac 00e0-fc11-2222
      [*CE2-GigabitEthernet0/1/0] commit
      [*CE2-GigabitEthernet0/1/0] quit
      [~CE2] interface gigabitethernet 0/1/1
      [~CE2-GigabitEthernet0/1/1] ptp delay-mechanism pdelay
      [*CE2-GigabitEthernet0/1/1] ptp enable
      [*CE2-GigabitEthernet0/1/1] ptp udp-egress source-ip 172.16.1.1 destination-ip 172.16.1.2
      [*CE2-GigabitEthernet0/1/1] ptp udp-egress destination-mac 00e0-fc33-2222
      [*CE2-GigabitEthernet0/1/1] commit
      [~CE2-GigabitEthernet0/1/1] quit

    6. Configure NodeB-3 to receive 1588v2 packets from CE2. The configuration details are not provided here.
  4. Configure CE2 to use WAN clock techniques to transmit clock signals to NodeB-2.
  5. Configure 1588v2 packet attributes on PE1, PE2, CE1, and CE2.
    1. Configure CE1.

      [~CE1] interface gigabitethernet 0/1/8
      [~CE1-GigabitEthernet0/1/8] ptp announce receipt-timeout 10
      [*CE1-GigabitEthernet0/1/8] ptp min-pdelayreq-interval 10
      [*CE1-GigabitEthernet0/1/8] commit
      [~CE1-GigabitEthernet0/1/8] quit
      [~CE1] interface gigabitethernet 0/1/0
      [~CE1-GigabitEthernet0/1/0] ptp announce-drop enable
      [*CE1-GigabitEthernet0/1/0] commit

    2. Configure CE2.

      [~CE2] interface gigabitethernet 0/1/0
      [~CE2-GigabitEthernet0/1/0] ptp announce receipt-timeout 10
      [*CE2-GigabitEthernet0/1/0] ptp min-pdelayreq-interval 10
      [*CE2-GigabitEthernet0/1/0] commit
      [~CE2-GigabitEthernet0/1/0] quit
      [~CE2] interface gigabitethernet 0/1/1
      [~CE2-GigabitEthernet0/1/1] ptp announce-drop enable
      [*CE2-GigabitEthernet0/1/1] commit

    3. Configure PE1.

      [~PE1] interface gigabitethernet 0/1/8
      [~PE1-GigabitEthernet0/1/8] ptp announce receipt-timeout 10
      [*PE1-GigabitEthernet0/1/8] commit
      [~PE1-GigabitEthernet0/1/8] quit
      [~PE1] interface gigabitethernet 0/1/0
      [~PE1-GigabitEthernet0/1/0] ptp announce-interval 8
      [*PE1-GigabitEthernet0/1/0] ptp min-pdelayreq-interval 10
      [*PE1-GigabitEthernet0/1/0] commit
      [~PE1-GigabitEthernet0/1/0] quit

    4. Configure PE2.

      [~PE2] interface gigabitethernet 0/1/8
      [~PE2-GigabitEthernet0/1/8] ptp announce receipt-timeout 10
      [*PE2-GigabitEthernet0/1/8] commit
      [*PE2-GigabitEthernet0/1/8] quit
      [~PE2] interface gigabitethernet 0/1/0
      [~PE2-GigabitEthernet0/1/0] ptp announce-interval 8
      [*PE2-GigabitEthernet0/1/0] ptp min-pdelayreq-interval 10
      [*PE2-GigabitEthernet0/1/0] commit
      [~PE2-GigabitEthernet0/1/0] quit

  6. Verify the configuration.

    After completing the configurations, run the display ptp all state command to view the 1588v2 operating status. The following example uses the command output on CE1. The command output shows that GE 0/1/8 of CE1 is working in the Slave state, the grandmaster clock ID is 000a0bfffe0c0dd4, and the parent clock ID is also 000a0bfffe0c0dd4. CE1 has synchronized with the master clock source.

    <CE1> display ptp all state
      Device config info
      ------------------------------------------------------------------
      PTP state         :enabled    Domain  value      :1
      Slave only        :no         Device type        :BC
      Set port state    :no         Local clock ID     :000a0bfffe0c0d42
      Acl               :no         Virtual clock ID   :no
      Acr               :no         Time lock success  :yes
      Asymmetry measure :disable    Passive measure    :disable
    
      BMC run info
      ------------------------------------------------------------------
      Grand clock ID    :000a0bfffe0c0dd4
      Receive number    :GigabitEthernet0/1/8
      Parent clock ID   :000a0bfffe0c0dd4
      Parent portnumber :6417
      Priority1         :128        Priority2          :128
      Step removed      :1          Clock accuracy     :49
      Clock class       :187        Time Source        :160
      UTC Offset        :0          UTC Offset Valid   :False
      Timescale         :ARB        Time Traceable     :False
      Leap              :None       Frequence Traceable:False
      Offset scaled     :0xffff     Sync uncertain     :False
    
      Port info
      Name                  State        Delay-mech Ann-timeout Type Domain
      ------------------------------------------------------------------------
      GigabitEthernet0/1/8  slave        pdelay      10          BC   1
      Time Performance Statistics(ns): Slot X  Card X  Port X
      ------------------------------------------------------------------------
      Realtime(T2-T1)   :534               Pathdelay     :0
      Max(T2-T1)        :887704804
      Min(T2-T1)        :512
    
      Clock source info
      Clock Pri1 Pri2 Accuracy Class TimeSrc Signal Switch Direction In-Status
      ------------------------------------------------------------------------
      local   200  128  0x31     187   0xa0     -      -      -         -
      bits1   128  128  0x20       6   0x20     none   off   -/-        abnormal

Configuration Files

  • CE1 configuration file

    #
     sysname CE1
    #
     ptp enable
     ptp device-type bc
     ptp domain 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 172.16.0.2 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce receipt-timeout 10
     ptp min-pdelayreq-interval 10
     ptp udp-egress source-ip 172.16.0.2 destination-ip 172.16.0.1
     ptp udp-egress destination-mac 00e0-fc11-1111
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.10.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp min-pdelayreq-interval 10
     ptp announce-drop enable
     ptp udp-egress source-ip 10.10.0.1 destination-ip 10.10.0.2
     ptp udp-egress destination-mac 00e0-fc33-1111
    #
     ospf 1
     area 0.0.0.0
     network 172.16.0.0 0.0.0.255
     network 10.10.0.0 0.0.0.255
    #
      
  • CE2 configuration file

    #
     sysname CE2
    #
     ptp enable
     ptp device-type bc
     ptp domain 1
     clock manual source ptp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.0.2 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce receipt-timeout 10
     ptp min-pdelayreq-interval 10
     ptp udp-egress source-ip 192.168.0.2 destination-ip 192.168.0.1
     ptp udp-egress destination-mac 00e0-fc11-2222
    #
    interface GigabitEthernet0/1/1
     undo shutdown
     ip address 172.16.1.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce-drop enable
     ptp udp-egress source-ip 172.16.1.1 destination-ip 172.16.1.2
     ptp udp-egress destination-mac 00e0-fc33-2222
    #
     ospf 1
     area 0.0.0.0
     network 192.168.0.0 0.0.0.255
     network 172.16.1.0 0.0.0.255
    #
      
  • PE1 configuration file

    #
     sysname PE1
    #
     ptp enable
     clock bits-type bits1 1pps input
     ptp clock-source bits1 on
     ptp clock-source bits1 priority1 2
     clock source ptp synchronization enable
     clock source ptp priority 1
     ptp device-type bc
     ptp domain 1
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 172.16.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce-interval 8
     ptp min-delayreq-interval 10
     ptp udp-egress source-ip 172.16.0.1 destination-ip 172.16.0.2
     ptp udp-egress destination-mac 00e0-fc22-1111
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 10.0.0.1 255.255.255.0
     ptp announce receipt-timeout 10
     ptp udp-egress source-ip 10.0.0.1 destination-ip 10.0.0.2
     ptp udp-egress destination-mac 00e0-fc22-2222
    #
     ospf 1
     area 0.0.0.0
     network 10.0.0.0 0.0.0.255
     network 172.16.0.0 0.0.0.255
    #
  • PE2 configuration file

    #
     sysname PE2
    #
     ptp enable
     clock bits-type bits1 1pps input
     ptp clock-source bits1 on
     ptp clock-source bits1 priority1 1
     clock source ptp synchronization enable
     clock source ptp priority 1
     ptp device-type bc
     ptp domain 1
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.0.1 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp announce-interval 8
     ptp min-delayreq-interval 10
     ptp udp-egress source-ip 192.168.0.1 destination-ip 192.168.0.2
     ptp udp-egress destination-mac 00e0-fc22-4444
    interface gigabitethernet 0/1/8
     undo shutdown
     ip address 10.0.0.2 255.255.255.0
     ptp enable
     ptp delay-mechanism pdelay
     ptp udp-egress source-ip 10.0.0.2 destination-ip 10.0.0.1
     ptp udp-egress destination-mac 00e0-fc22-1111
     ptp announce receipt-timeout 10
    #
     ospf 1
     area 0.0.0.0
     network 10.0.0.0 0.0.0.255
     network 192.168.0.0 0.0.0.255
    #
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
Next topic >