Example for Configuring Interface-specific UCMP for IP Packet Forwarding

This section provides an example for configuring interface-specific UCMP for IP packet forwarding.

Networking Requirements

As shown in Figure 1, Device A and Device E are connected through three links that pass through Device B, Device C, and Device D, respectively. The bandwidth of the link from Device A to Device B is 1 Gbit/s, that from Device A to Device C is 1 Gbit/s, and that from Device A to Device D is 10 Gbit/s. To allow traffic to be load balanced among these paths, configure UCMP for IP packet forwarding. In this example, configure UCMP on specified interfaces, not on an entire router.

Figure 1 Configuring interface-specific UCMP

The configurations in this example are performed on Device A, Device B, Device C, Device D, and Device E. HUAWEI NetEngine 8000 F Seriess can function as Device A through Device E.


Table 1 Device names, interface names, and IP addresses

Device Name

Interface Name

IP Address

Device A

GE 0/1/24

10.30.1.1/24

GE 0/1/16

10.40.1.1/24

GE 0/1/8

10.50.1.1/24

Device B

GE 0/1/0

10.30.1.2/24

GE 0/1/8

10.60.1.2/24

Device C

GE 0/1/0

10.40.1.2/24

GE 0/1/8

10.70.1.2/24

Device D

GE 0/1/0

10.50.1.2/24

GE 0/1/8

10.80.1.2/24

Device E

GE 0/1/24

10.60.1.1/24

GE 0/1/16

10.70.1.1/24

GE 0/1/8

10.80.1.1/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP on each router. IS-IS is used in this example.

  2. Enable UCMP on each interface, allowing three paths between Device A and Device E to perform UCMP during IP packet forwarding.

Data Preparation

To complete the configuration, you need the following data:

  • Type and number of each interface

  • IP address of each interface

  • IS-IS area ID and level for each router

Procedure

  1. Assign an IP address to each interface. For configuration details, see Configuration Files in this section.
  2. Configure basic IS-IS functions.

    # Configure Device A.

    [~DeviceA] isis 1
    [*DeviceA-isis-1] is-level level-1
    [*DeviceA-isis-1] network-entity 10.0000.0000.0001.00
    [*DeviceA-isis-1] commit
    [~DeviceA-isis-1] quit
    [~DeviceA] interface gigabitethernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] isis enable 1
    [*DeviceA-GigabitEthernet0/1/0] quit
    [*DeviceA] interface gigabitethernet 0/1/8
    [*DeviceA-GigabitEthernet0/1/8] isis enable 1
    [*DeviceA-GigabitEthernet0/1/8] quit
    [*DeviceA] interface gigabitethernet 0/1/24
    [*DeviceA-GigabitEthernet0/1/24] isis enable 1
    [*DeviceA-GigabitEthernet0/1/24] quit
    [*DeviceA] interface gigabitethernet 0/1/16
    [*DeviceA-GigabitEthernet0/1/16] isis enable 1
    [*DeviceA-GigabitEthernet0/1/16] quit
    [*DeviceA] commit

    # Configure Device B.

    [~DeviceB] isis 1
    [*DeviceB-isis-1] is-level level-1
    [*DeviceB-isis-1] network-entity 10.0000.0000.0002.00
    [*DeviceB-isis-1] commit
    [~DeviceB-isis-1] quit
    [~DeviceB] interface gigabitethernet 0/1/0
    [~DeviceB-GigabitEthernet0/1/0] isis enable 1
    [*DeviceB-GigabitEthernet0/1/0] quit
    [*DeviceB] interface gigabitethernet 0/1/8
    [*DeviceB-GigabitEthernet0/1/8] isis enable 1
    [*DeviceB-GigabitEthernet0/1/8] quit
    [*DeviceB] commit

    # Configure Device C.

    [~DeviceC] isis 1
    [*DeviceC-isis-1] is-level level-1
    [*DeviceC-isis-1] network-entity 10.0000.0000.0003.00
    [*DeviceC-isis-1] commit
    [~DeviceC-isis-1] quit
    [~DeviceC] interface gigabitethernet 0/1/0
    [~DeviceC-GigabitEthernet0/1/0] isis enable 1
    [*DeviceC-GigabitEthernet0/1/0] quit
    [*DeviceC] interface gigabitethernet 0/1/8
    [*DeviceC-GigabitEthernet0/1/8] isis enable 1
    [*DeviceC-GigabitEthernet0/1/8] quit
    [*DeviceC] commit

    # Configure Device D.

    [~DeviceD] isis 1
    [*DeviceD-isis-1] is-level level-1
    [*DeviceD-isis-1] network-entity 10.0000.0000.0004.00
    [*DeviceD-isis-1] commit
    [~DeviceD-isis-1] quit
    [~DeviceD] interface gigabitethernet 0/1/0
    [~DeviceD-GigabitEthernet0/1/0] isis enable 1
    [*DeviceD-GigabitEthernet0/1/0] quit
    [*DeviceD] interface gigabitethernet 0/1/8
    [*DeviceD-GigabitEthernet0/1/8] isis enable 1
    [*DeviceD-GigabitEthernet0/1/8] quit
    [*DeviceD] commit

    # Configure Device E.

    [~DeviceE] isis 1
    [*DeviceE-isis-1] is-level level-1
    [*DeviceE-isis-1] network-entity 10.0000.0000.0005.00
    [*DeviceE-isis-1] commit
    [~DeviceE-isis-1] quit
    [~DeviceE] interface gigabitethernet 0/1/0
    [~DeviceE-GigabitEthernet0/1/0] isis enable 1
    [*DeviceE-GigabitEthernet0/1/0] quit
    [*DeviceE] interface gigabitethernet 0/1/8
    [*DeviceE-GigabitEthernet0/1/8] isis enable 1
    [*DeviceE-GigabitEthernet0/1/8] quit
    [*DeviceE] interface gigabitethernet 0/1/24
    [*DeviceE-GigabitEthernet0/1/24] isis enable 1
    [*DeviceE-GigabitEthernet0/1/24] quit
    [*DeviceE] interface gigabitethernet 0/1/16
    [*DeviceE-GigabitEthernet0/1/16] isis enable 1
    [*DeviceE-GigabitEthernet0/1/16] quit
    [*DeviceE] commit

  3. Enable UCMP on every outbound interface of Device A.

    [~routerA] interface gigabitethernet 0/1/8
    [~routerA-GigabitEthernet0/1/8] load-balance unequal-cost enable
    [*routerA-GigabitEthernet0/1/8] quit
    [*routerA] interface gigabitethernet 0/1/24
    [*routerA-GigabitEthern0/1/24] load-balance unequal-cost enable
    [*routerA-GigabitEthern0/1/24] quit
    [*routerA] interface gigabitethernet 0/1/16
    [*routerA-GigabitEthernet0/1/16] load-balance unequal-cost enable
    [*routerA-GigabitEthernet0/1/16] quit
    [*routerA] commit

    The traffic tester measures the traffic bandwidth values on GE 0/1/24 (10.30.1.1/24), GE 0/1/16 (10.40.1.1/24), and GE 0/1/8 (10.50.1.1/24) of Device A and obtains the traffic ratio of 1:1:10.

Configuration Files

  • Device A configuration file

    #
     sysname routerA
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     load-balance unequal-cost enable
     ip address 10.50.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/16
     undo shutdown
     load-balance unequal-cost enable
     ip address 10.40.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/24
     undo shutdown
     load-balance unequal-cost enable
     ip address 10.30.1.1 255.255.255.0
     isis enable 1
    #
    return
    
  • Device B configuration file

    #
     sysname routerB
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.30.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 10.60.1.2 255.255.255.0
     isis enable 1
    #
    return
    
  • Device C configuration file

    #
     sysname routerC
    #
    isis 1
    is-level level-1
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.40.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 10.70.1.2 255.255.255.0
     isis enable 1
    #
    return
    
  • Device D configuration file

    #
     sysname routerD
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0004.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.50.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 10.80.1.2 255.255.255.0
     isis enable 1
    #
    return
    
  • Device E configuration file

    #
     sysname routerE
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0005.00
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.20.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 10.80.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/16
     undo shutdown
     ip address 10.70.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/24
     undo shutdown
     ip address 10.60.1.1 255.255.255.0
     isis enable 1
    #
    return
    
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
Next topic >