This section provides an example for configuring peer locator-based iFIT end-to-end measurement on an L3VPN over SRv6 network.
L3VPN over SRv6 uses public SRv6 tunnels to carry L3VPN services. You can configure iFIT on an L3VPN over SRv6 network to monitor the packet loss rate and latency of the links between the PEs in real time. This enables you to respond to network issues if service quality deteriorates and therefore meet users' service quality requirements.
On the L3VPN over SRv6 network shown in Figure 1, service flows enter the network through PE1, traverses the P, and leaves the network through PE2.
Configure packet loss and latency measurement on the PEs to collect packet loss rate and latency statistics at intervals.
IPv6 address of each interface as listed in Figure 1
# Configure the P to import clock signals from BITS0.
[~P] clock bits-type bits0 2mhz [*P] clock source bits0 synchronization enable [*P] clock source bits0 priority 1 [*P] commit
[~P] ptp enable [*P] ptp domain 1 [*P] ptp device-type bc [*P] ptp clock-source local clock-class 185 [*P] clock source ptp synchronization enable [*P] clock source ptp priority 1 [*P] commit
[~PE1] ptp enable [*PE1] ptp domain 1 [*PE1] ptp device-type bc [*PE1] ptp clock-source local clock-class 185 [*PE1] clock source ptp synchronization enable [*PE1] clock source ptp priority 1 [*PE1] commit
[~PE2] ptp enable [*PE2] ptp domain 1 [*PE2] ptp device-type bc [*PE2] ptp clock-source local clock-class 185 [*PE2] clock source ptp synchronization enable [*PE2] clock source ptp priority 1 [*PE2] commit
[~P] interface gigabitethernet 0/1/0 [~P-GigabitEthernet0/1/0] ptp enable [*P-GigabitEthernet0/1/0] commit [~P-GigabitEthernet0/1/0] quit [~P] interface gigabitethernet 0/1/8 [~P-GigabitEthernet0/1/8] ptp enable [*P-GigabitEthernet0/1/8] commit [~P-GigabitEthernet0/1/8] quit [~P] interface gigabitethernet 0/1/16 [~P-GigabitEthernet0/1/16] ptp enable [*P-GigabitEthernet0/1/16] commit [~P-GigabitEthernet0/1/16] quit
[~PE1] interface gigabitethernet 0/1/0 [~PE1-GigabitEthernet0/1/0] ptp enable [*PE1-GigabitEthernet0/1/0] commit [~PE1-GigabitEthernet0/1/0] quit [~PE1] interface gigabitethernet 0/1/8 [~PE1-GigabitEthernet0/1/8] ptp enable [*PE1-GigabitEthernet0/1/8] commit [~PE1-GigabitEthernet0/1/8] quit
[~PE2] interface gigabitethernet 0/1/0 [~PE2-GigabitEthernet0/1/0] ptp enable [*PE2-GigabitEthernet0/1/0] commit [~PE2-GigabitEthernet0/1/0] quit [~PE2] interface gigabitethernet 0/1/8 [~PE2-GigabitEthernet0/1/8] ptp enable [*PE2-GigabitEthernet0/1/8] commit [~PE2-GigabitEthernet0/1/8] quit
# Configure PE1.
<PE1> system-view [~PE1] ifit [*PE1-ifit] node-id 10 [*PE1-ifit] instance 1 [*PE1-ifit-instance-1] measure-mode e2e [*PE1-ifit-instance-1] interval 10 [*PE1-ifit-instance-1] flow unidirectional source any destination any vpn-instance vpna peer-locator 2001:DB8:40::1 64 [*PE1-ifit-instance-1] binding interface gigabitethernet 0/1/8 [*PE1-ifit-instance-1] commit
[~PE1] display ifit static instance 1 ------------------------------------------------------------------------- Flow Classification : static Instance Id : 10 Instance-name : 1 Flow Id : 1900545 Flow Type : unidirectional Source IP Address/Mask Length : any Destination IP Address/Mask Length : any Protocol : any Source Port : any Destination Port : any Gtp : disable Gtp TeId : -- Dscp : -- Interface : GigabitEthernet0/1/8 vpn-instance : vpna Loss Measure : enable Delay Measure : enable Delay Per packet Measure : disable Disorder Measure : disable Gtpu Sequence Measure : disable Measure Mode : e2e Interval : 10(s) Tunnel Type : SRv6 Peer Locator: : 2001:DB8:40::1/64
<PE2> system-view [~PE2] ifit [*PE2-ifit] commit
# Run the display ifit dynamic-hop command to view the configuration and status of PE2.
[~PE2] display ifit dynamic-hop ------------------------------------------------------------------------- Flow Classification : dynamic-hop Instance Id : 514 Flow Id : 1900545 Flow Type : unidirectional Interface : GigabitEthernet0/1/8 Direction : egress Loss Measure : enable Delay Measure : enable Disorder Measure : disable Interval : 10(s)
[~PE1] telemetry [~PE1-telemetry] destination-group ifit [*PE1-telemetry-destination-group-ifit] ipv6-address 2001:DB8:101::1 port 10001 protocol grpc no-tls [*PE1-telemetry-destination-group-ifit] quit [*PE1-telemetry] sensor-group ifit [*PE1-telemetry-sensor-group-ifit] sensor-path huawei-ifit:ifit/huawei-ifit-statistics:flow-locator-statistics/flow-locator-statistic [*PE1-telemetry-sensor-group-ifit-path] quit [*PE1-telemetry-sensor-group-ifit] sensor-path huawei-ifit:ifit/huawei-ifit-statistics:flow-statistics/flow-statistic [*PE1-telemetry-sensor-group-ifit-path] quit [*PE1-telemetry-sensor-group-ifit] quit [*PE1-telemetry] subscription ifit [*PE1-telemetry-subscription-ifit] sensor-group ifit sample-interval 0 [*PE1-telemetry-subscription-ifit] destination-group ifit [*PE1-telemetry-subscription-ifit] commit
# sysname PE1 # ptp enable ptp domain 1 ptp device-type bc ptp clock-source local clock-class 185 # clock source ptp synchronization enable clock source ptp priority 1 # ip vpn-instance vpna ipv4-family route-distinguisher 100:1 apply-label per-instance vpn-target 111:1 export-extcommunity vpn-target 111:1 import-extcommunity # segment-routing ipv6 encapsulation source-address 2001:DB8:1::1 locator as1 ipv6-prefix 2001:DB8:100::1 64 static 32 # isis 1 is-level level-1 cost-style wide network-entity 10.0000.0000.0001.00 # ipv6 enable topology ipv6 segment-routing ipv6 locator as1 # interface GigabitEthernet0/1/0 undo shutdown ipv6 enable ipv6 address 2001:DB8:10::1/96 isis ipv6 enable 1 ptp enable # interface GigabitEthernet0/1/8 undo shutdown ip binding vpn-instance vpna ip address 10.1.1.1 255.255.255.0 ptp enable # interface LoopBack1 ipv6 enable ipv6 address 2001:DB8:1::1/64 isis ipv6 enable 1 # bgp 100 router-id 1.1.1.1 peer 2001:DB8:3::3 as-number 100 peer 2001:DB8:3::3 connect-interface LoopBack1 # ipv4-family unicast undo synchronization # ipv6-family unicast undo synchronization # ipv4-family vpnv4 policy vpn-target peer 2001:DB8:3::3 enable peer 2001:DB8:3::3 prefix-sid # ipv4-family vpn-instance vpna import-route direct segment-routing ipv6 locator as1 segment-routing ipv6 best-effort peer 10.1.1.2 as-number 65410 # ifit node-id 10 instance 1 interval 10 flow unidirectional source-ipv6 any destination-ipv6 any vpn-instance vpna peer-locator 2001:DB8:40::1 64 binding interface GigabitEthernet0/1/8 # telemetry # sensor-group ifit sensor-path huawei-ifit:ifit/huawei-ifit-statistics:flow-locator-statistics/flow-locator-statistic sensor-path huawei-ifit:ifit/huawei-ifit-statistics:flow-statistics/flow-statistic # destination-group ifit ipv6-address 2001:DB8:101::1 port 10001 protocol grpc no-tls # subscription ifit sensor-group ifit sample-interval 0 destination-group ifit # return
# sysname P # ptp enable ptp domain 1 ptp device-type bc ptp clock-source local clock-class 185 # clock source bits0 synchronization enable clock source bits0 priority 1 clock source ptp synchronization enable clock source ptp priority 1 clock bits-type bits0 2mhz # isis 1 is-level level-1 cost-style wide network-entity 10.0000.0000.0002.00 # ipv6 enable topology ipv6 # interface GigabitEthernet0/1/0 undo shutdown ipv6 enable ipv6 address 2001:DB8:10::2/96 isis ipv6 enable 1 ptp enable # interface GigabitEthernet0/1/8 undo shutdown ipv6 enable ipv6 address 2001:DB8:20::1/96 isis ipv6 enable 1 ptp enable # interface GigabitEthernet0/1/16 undo shutdown ipv6 enable ipv6 address 2001:DB8:30::1/96 ptp enable # interface LoopBack1 ipv6 enable ipv6 address 2001:DB8:2::2/64 isis ipv6 enable 1 # return
# sysname PE2 # ptp enable ptp domain 1 ptp device-type bc ptp clock-source local clock-class 185 # clock source ptp synchronization enable clock source ptp priority 1 # ip vpn-instance vpna ipv4-family route-distinguisher 200:1 apply-label per-instance vpn-target 111:1 export-extcommunity vpn-target 111:1 import-extcommunity # segment-routing ipv6 encapsulation source-address 2001:DB8:3::3 locator as1 ipv6-prefix 2001:DB8:40::1 64 static 32 # isis 1 is-level level-1 cost-style wide network-entity 10.0000.0000.0003.00 # ipv6 enable topology ipv6 segment-routing ipv6 locator as1 # interface GigabitEthernet0/1/0 undo shutdown ipv6 enable ipv6 address 2001:DB8:20::2/96 isis ipv6 enable 1 ptp enable # interface GigabitEthernet0/1/8 undo shutdown ip binding vpn-instance vpna ip address 10.2.1.1 255.255.255.0 ptp enable # interface LoopBack1 ipv6 enable ipv6 address 2001:DB8:3::3/64 isis ipv6 enable 1 # bgp 100 router-id 2.2.2.2 peer 2001:DB8:1::1 as-number 100 peer 2001:DB8:1::1 connect-interface LoopBack1 # ipv4-family unicast undo synchronization # ipv6-family unicast undo synchronization # ipv4-family vpnv4 policy vpn-target peer 2001:DB8:1::1 enable peer 2001:DB8:1::1 prefix-sid # ipv4-family vpn-instance vpna import-route direct segment-routing ipv6 locator as1 segment-routing ipv6 best-effort peer 10.2.1.2 as-number 65420 # ifit # return
#
sysname CE1
#
interface GigabitEthernet0/1/0
undo shutdown
ip address 10.1.1.2 255.255.255.0
#
interface LoopBack1
ip address 11.11.11.11 255.255.255.255
#
bgp 65410
peer 10.1.1.1 as-number 100
#
ipv4-family unicast
undo synchronization
network 11.11.11.11 255.255.255.255
peer 10.1.1.1 enable
#
return
#
sysname CE2
#
interface GigabitEthernet0/1/0
undo shutdown
ip address 10.2.1.2 255.255.255.0
#
interface LoopBack1
ip address 22.22.22.22 255.255.255.255
#
bgp 65420
peer 10.2.1.1 as-number 100
#
ipv4-family unicast
undo synchronization
network 22.22.22.22 255.255.255.255
peer 10.2.1.1 enable
#
return