This section provides an example for configuring bidirectional flow-based iFIT hop-by-hop measurement on an L3VPN.
You can configure iFIT on the L3VPN to monitor the packet loss rate and latency of the links between the PEs in real time. This enables you to respond to network issues if service quality deteriorates and therefore meet users' service quality requirements. iFIT supports bidirectional flow-based performance measurement. A backward flow instance is automatically generated based on the forward flow created on one device. On a live network, there are a large number of access devices but only a few core-layer devices. Therefore, creating a bidirectional flow on a core-layer device can greatly reduce the configuration and maintenance workload.
On the L3VPN shown in Figure 1, PE1 is a core-layer device, and PE2 is an access-layer device.
Configure packet loss and latency measurement on the PEs to collect packet loss rate and latency statistics at intervals.
IP address of each interface as listed in Figure 1
Target flow's source IP address (10.11.1.1) and destination IP address (10.22.2.2)
# Configure the P to import clock signals from BITS0.
[~P] clock bits-type bits0 2mhz [*P] clock source bits0 synchronization enable [*P] clock source bits0 priority 1 [*P] commit
[~P] ptp enable [*P] ptp domain 1 [*P] ptp device-type bc [*P] ptp clock-source local clock-class 185 [*P] clock source ptp synchronization enable [*P] clock source ptp priority 1 [*P] commit
[~PE1] ptp enable [*PE1] ptp domain 1 [*PE1] ptp device-type bc [*PE1] ptp clock-source local clock-class 185 [*PE1] clock source ptp synchronization enable [*PE1] clock source ptp priority 1 [*PE1] commit
[~PE2] ptp enable [*PE2] ptp domain 1 [*PE2] ptp device-type bc [*PE2] ptp clock-source local clock-class 185 [*PE2] clock source ptp synchronization enable [*PE2] clock source ptp priority 1 [*PE2] commit
[~P] interface gigabitethernet 0/1/0 [~P-GigabitEthernet0/1/0] ptp enable [*P-GigabitEthernet0/1/0] commit [~P-GigabitEthernet0/1/0] quit [~P] interface gigabitethernet 0/1/8 [~P-GigabitEthernet0/1/8] ptp enable [*P-GigabitEthernet0/1/8] commit [~P-GigabitEthernet0/1/8] quit [~P] interface gigabitethernet 0/1/16 [~P-GigabitEthernet0/1/16] ptp enable [*P-GigabitEthernet0/1/16] commit [~P-GigabitEthernet0/1/16] quit
[~PE1] interface gigabitethernet 0/1/0 [~PE1-GigabitEthernet0/1/0] ptp enable [*PE1-GigabitEthernet0/1/0] commit [~PE1-GigabitEthernet0/1/0] quit [~PE1] interface gigabitethernet 0/1/8 [~PE1-GigabitEthernet0/1/8] ptp enable [*PE1-GigabitEthernet0/1/8] commit [~PE1-GigabitEthernet0/1/8] quit
[~PE2] interface gigabitethernet 0/1/0 [~PE2-GigabitEthernet0/1/0] ptp enable [*PE2-GigabitEthernet0/1/0] commit [~PE2-GigabitEthernet0/1/0] quit [~PE2] interface gigabitethernet 0/1/8 [~PE2-GigabitEthernet0/1/8] ptp enable [*PE2-GigabitEthernet0/1/8] commit [~PE2-GigabitEthernet0/1/8] quit
# Configure PE1.
<PE1> system-view [~PE1] ifit [*PE1-ifit] node-id 10 [*PE1-ifit] encapsulation nexthop 3.3.3.9 [*PE1-ifit] instance 1 [*PE1-ifit-instance-1] measure-mode trace [*PE1-ifit-instance-1] interval 10 [*PE1-ifit-instance-1] flow bidirectional source 10.11.1.1 destination 10.22.2.2 dscp 63 vpn-instance vpna [*PE1-ifit-instance-1] binding interface gigabitethernet 0/1/0 [*PE1-ifit-instance-1] commit
[~PE1] display ifit static instance 1 ------------------------------------------------------------------------- Flow Classification : static Instance Id : 10 Instance-name : 1 Flow Id : 1900545 Flow Type : bidirectional Source IP Address/Mask Length : 10.11.1.1/32 Destination IP Address/Mask Length : 10.22.2.2/32 Protocol : any Source Port : any Destination Port : any Gtp : disable Gtp TeId : -- Dscp : 63 Interface : GigabitEthernet0/1/0 vpn-instance : vpna Loss Measure : enable Delay Measure : enable Delay Per packet Measure : disable Disorder Measure : disable Gtpu Sequence Measure : disable Measure Mode : trace Interval : 10(s) Tunnel Type : --
# Configure the P.
<P> system-view [~P] ifit [*P-ifit] commit
<PE2> system-view [~PE2] ifit [*PE2-ifit] node-id 20 [*PE2-ifit] encapsulation nexthop 1.1.1.9 [*PE2-ifit] commit
# Run the display ifit dynamic command to view the configuration and status of PE2.
[~PE2] display ifit dynamic ------------------------------------------------------------------------- Flow Classification : dynamic Instance Id : 100 Flow Id : 2099183 Flow Type : unidirectional Source IP Address/Mask Length : 10.22.2.2/32 Destination IP Address/Mask Length : 10.11.1.1/32 Protocol : any Source Port : any Destination Port : any Gtp : disable Gtp TeId : -- Dscp : 63 Interface : GigabitEthernett0/1/0 vpn-instance : vpna Loss Measure : enable Delay Measure : enable Delay Per packet Measure : disable Disorder Measure : disable Gtpu Sequence Measure : disable Measure Mode : e2e Interval : 10(s) Tunnel Type : --
[~PE1] telemetry [~PE1-telemetry] destination-group ifit [*PE1-telemetry-destination-group-ifit] ipv4-address 192.168.100.100 port 10001 protocol grpc no-tls [*PE1-telemetry-destination-group-ifit] quit [*PE1-telemetry] sensor-group ifit [*PE1-telemetry-sensor-group-ifit] sensor-path huawei-ifit:ifit/huawei-ifit-statistics:flow-hop-statistics/flow-hop-statistic [*PE1-telemetry-sensor-group-ifit-path] quit [*PE1-telemetry-sensor-group-ifit] sensor-path huawei-ifit:ifit/huawei-ifit-statistics:flow-statistics/flow-statistic [*PE1-telemetry-sensor-group-ifit-path] quit [*PE1-telemetry-sensor-group-ifit] quit [*PE1-telemetry] subscription ifit [*PE1-telemetry-subscription-ifit] sensor-group ifit sample-interval 0 [*PE1-telemetry-subscription-ifit] destination-group ifit [*PE1-telemetry-subscription-ifit] commit
# sysname PE1 # ptp enable ptp domain 1 ptp device-type bc ptp clock-source local clock-class 185 # clock source ptp synchronization enable clock source ptp priority 1 # ip vpn-instance vpna ipv4-family route-distinguisher 100:1 apply-label per-instance tnl-policy p1 vpn-target 111:1 export-extcommunity vpn-target 111:1 import-extcommunity # mpls lsr-id 1.1.1.9 # mpls mpls te # explicit-path pe2 next sid label 16200 type prefix next sid label 16300 type prefix # segment-routing # isis 1 is-level level-2 cost-style wide network-entity 10.0000.0000.0001.00 traffic-eng level-2 segment-routing mpls segment-routing global-block 16000 20000 # interface GigabitEthernet0/1/0 undo shutdown ip binding vpn-instance vpna ip address 10.1.1.2 255.255.255.0 ptp enable # interface GigabitEthernet0/1/8 undo shutdown ip address 172.16.1.1 255.255.255.0 isis enable 1 ptp enable # interface LoopBack1 ip address 1.1.1.9 255.255.255.255 isis enable 1 isis prefix-sid absolute 16100 # bgp 100 peer 3.3.3.9 as-number 100 peer 3.3.3.9 connect-interface LoopBack1 # ipv4-family unicast undo synchronization peer 3.3.3.9 enable # ipv4-family vpnv4 policy vpn-target peer 3.3.3.9 enable # ipv4-family vpn-instance vpna peer 10.1.1.1 as-number 65410 # interface Tunnel1 ip address unnumbered interface LoopBack1 tunnel-protocol mpls te destination 3.3.3.9 mpls te signal-protocol segment-routing mpls te tunnel-id 1 mpls te path explicit-path pe2 # tunnel-policy p1 tunnel select-seq sr-te load-balance-number 1 # ifit node-id 10 encapsulation nexthop 3.3.3.9 instance 1 measure-mode trace interval 10 flow bidirectional source 10.11.1.1 destination 10.22.2.2 dscp 63 vpn-instance vpna binding interface GigabitEthernet0/1/0 # telemetry # sensor-group ifit sensor-path huawei-ifit:ifit/huawei-ifit-statistics:flow-hop-statistics/flow-hop-statistic sensor-path huawei-ifit:ifit/huawei-ifit-statistics:flow-statistics/flow-statistic # destination-group ifit ipv4-address 192.168.100.100 port 10001 protocol grpc no-tls # subscription ifit sensor-group ifit sample-interval 0 destination-group ifit # return
# sysname P1 # ptp enable ptp domain 1 ptp device-type bc ptp clock-source local clock-class 185 # clock source bits0 synchronization enable clock source bits0 priority 1 clock source ptp synchronization enable clock source ptp priority 1 clock bits-type bits0 2mhz # mpls lsr-id 2.2.2.9 # mpls mpls te # segment-routing # isis 1 is-level level-2 cost-style wide network-entity 10.0000.0000.0002.00 traffic-eng level-2 segment-routing mpls segment-routing global-block 16000 20000 # interface GigabitEthernet0/1/0 undo shutdown ip address 172.16.1.2 255.255.255.0 isis enable 1 ptp enable # interface GigabitEthernet0/1/8 undo shutdown ip address 172.17.1.1 255.255.255.0 isis enable 1 ptp enable # interface GigabitEthernet0/1/16 undo shutdown ip address 172.18.1.1 255.255.255.0 ptp enable # interface LoopBack1 ip address 2.2.2.9 255.255.255.255 isis enable 1 isis prefix-sid absolute 16200 # ifit # return
# sysname PE2 # ptp enable ptp domain 1 ptp device-type bc ptp clock-source local clock-class 185 # clock source ptp synchronization enable clock source ptp priority 1 # ip vpn-instance vpna ipv4-family route-distinguisher 200:1 apply-label per-instance tnl-policy p1 vpn-target 111:1 export-extcommunity vpn-target 111:1 import-extcommunity # mpls lsr-id 3.3.3.9 # mpls mpls te # explicit-path pe1 next sid label 16200 type prefix next sid label 16100 type prefix # segment-routing # isis 1 is-level level-2 cost-style wide network-entity 10.0000.0000.0003.00 traffic-eng level-2 segment-routing mpls segment-routing global-block 16000 20000 # interface GigabitEthernet0/1/0 undo shutdown ip binding vpn-instance vpna ip address 10.2.1.2 255.255.255.0 ptp enable # interface GigabitEthernet0/1/8 undo shutdown ip address 172.17.1.2 255.255.255.0 isis enable 1 ptp enable # interface LoopBack1 ip address 3.3.3.9 255.255.255.255 isis enable 1 isis prefix-sid absolute 16300 # interface Tunnel1 ip address unnumbered interface LoopBack1 tunnel-protocol mpls te destination 1.1.1.9 mpls te signal-protocol segment-routing mpls te tunnel-id 1 mpls te path explicit-path pe1 # bgp 100 peer 1.1.1.9 as-number 100 peer 1.1.1.9 connect-interface LoopBack1 # ipv4-family unicast undo synchronization peer 1.1.1.9 enable # ipv4-family vpnv4 policy vpn-target peer 1.1.1.9 enable # ipv4-family vpn-instance vpna peer 10.2.1.1 as-number 65420 # tunnel-policy p1 tunnel select-seq sr-te load-balance-number 1 # ifit node-id 20 encapsulation nexthop 1.1.1.9 # return
#
sysname CE1
#
interface GigabitEthernet0/1/0
undo shutdown
ip address 10.1.1.1 255.255.255.0
#
interface LoopBack1
ip address 10.11.1.1 255.255.255.255
#
bgp 65410
peer 10.1.1.2 as-number 100
#
ipv4-family unicast
undo synchronization
peer 10.1.1.2 enable
network 10.11.1.1 255.255.255.255
#
return
#
sysname CE2
#
interface GigabitEthernet0/1/0
undo shutdown
ip address 10.2.1.1 255.255.255.0
#
interface LoopBack1
ip address 10.22.2.2 255.255.255.255
#
bgp 65420
peer 10.2.1.2 as-number 100
#
ipv4-family unicast
undo synchronization
peer 10.2.1.2 enable
network 10.22.2.2 255.255.255.255
#
return