< Home

Example for Configuring the MAC Ping Test

Networking Requirements

In Figure 1:

  • CFM is enabled on Switch A and Switch B.

  • MAs and MDs are configured on Switch A and Switch B.

The NQA MAC Ping test is used to test the connectivity between Switch A and Switch B.

Figure 1 Networking diagram for configuring the MAC Ping test

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure Switch A as the NQA client.

  2. Configure Switch B as the NQA server.

  3. Create a MAC Ping test on Switch A.

Procedure

  1. Configure the MA and MD between Switch A and Switch B.

    # Configure Switch A.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 11
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 11
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 11
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] cfm enable
    [SwitchA] cfm md test
    [SwitchA-md-test] ma test
    [SwitchA-md-test-ma-test] map vlan 11
    [SwitchA-md-test-ma-test] mep mep-id 11 interface gigabitethernet0/0/1 outward
    [SwitchA-md-test-ma-test] mep ccm-send mep-id 11 enable
    [SwitchA-md-test-ma-test] remote-mep mep-id 12
    [SwitchA-md-test-ma-test] remote-mep ccm-receive mep-id 12 enable
    [SwitchA-md-test-ma-test] quit
    [SwitchA-md-test] quit

    # Configure Switch B.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 11
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet0/0/1] port hybrid pvid vlan 11
    [SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 11
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] cfm enable
    [SwitchB] cfm md test
    [SwitchB-md-test] ma test
    [SwitchB-md-test-ma-test] map vlan 11
    [SwitchB-md-test-ma-test] mep mep-id 12 interface gigabitethernet0/0/1 outward
    [SwitchB-md-test-ma-test] mep ccm-send mep-id 12 enable
    [SwitchB-md-test-ma-test] remote-mep mep-id 11
    [SwitchB-md-test-ma-test] remote-mep ccm-receive mep-id 11 enable
    [SwitchB-md-test-ma-test] quit
    [SwitchB-md-test] quit

  2. # Enable the NQA client and create a MAC Ping test for a common tunnel on Switch A.

    [SwitchA]nqa test-instance admin macping
    [SwitchA-nqa-admin-macping] test-type macping
    [SwitchA-nqa-admin-macping] md test ma test
    [SwitchA-nqa-admin-macping] destination-address remote-mep mep-id 12

  3. Perform the test.

    [SwitchA-nqa-admin-macping] start now

  4. Verify the test result.

    [SwitchA-nqa-admin-macping] display nqa results test-instance admin macping
    
     NQA entry(admin, macping) :testflag is inactive ,testtype is macping
      1 . Test 1 result   The test is finished
       SendProbe:3                          ResponseProbe:3
       Completion:success                   RTD OverThresholds number:0
       Min/Max/Avg/Sum RTT:3/3/3/9          RTT Square Sum:27
       NumOfRTT:3                           Drop operation number:0
       Operation sequence errors number:0   RTT Stats errors number:0
       System busy operation number:0       Operation timeout number:0
       Min Positive SD:0                    Min Positive DS:0
       Max Positive SD:0                    Max Positive DS:0
       Positive SD Number:0                 Positive DS Number:0
       Positive SD Sum:0                    Positive DS Sum:0
       Positive SD Square Sum:0             Positive DS Square Sum:0
       Min Negative SD:0                    Min Negative DS:0
       Max Negative SD:0                    Max Negative DS:0
       Negative SD Number:0                 Negative DS Number:0
       Negative SD Sum:0                    Negative DS Sum:0
       Negative SD Square Sum:0             Negative DS Square Sum:0
       Min Delay SD:0                       Min Delay DS:0
       Avg Delay SD:0                       Avg Delay DS:0
       Max Delay SD:0                       Max Delay DS:0
       Packet Loss SD:0                     Packet Loss DS:0
       Packet Loss Unknown:0                Average of Jitter:0
       Average of Jitter SD:0               Average of Jitter DS:0
       Jitter out value:0.0000000           Jitter in value:0.0000000
       NumberOfOWD:0                        OWD SD Sum:0  
       OWD DS Sum:0                         TimeStamp unit: ms   
       Packet Rewrite Number: 0             Packet Rewrite Ratio: 0% 
       Packet Disorder Number: 0            Packet Disorder Ratio: 0%  
       Fragment-disorder Number: 0          Fragment-disorder Ratio: 0%  
       Start time: --
       End time: --  

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 11
    #
    cfm enable
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 11
     port hybrid untagged vlan 11
    #
    cfm md test
     ma test
      map vlan 11
      mep mep-id 11 interface GigabitEthernet0/0/1 outward
      mep ccm-send mep-id 11 enable
      remote-mep mep-id 12
      remote-mep ccm-receive mep-id 12 enable
    #
    nqa test-instance admin macping
     test-type macping
     destination-address remote-mep mep-id 12
     md test ma test
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 11
    #
    cfm enable
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 11
     port hybrid untagged vlan 11
    #
    cfm md test
     ma test
      map vlan 11
      mep mep-id 12 interface GigabitEthernet0/0/1 outward
      mep ccm-send mep-id 12 enable
      remote-mep mep-id 11
      remote-mep ccm-receive mep-id 11 enable
    #
    return
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >