< Home

Example for Configuring SEP on a Multi-Ring Network

Networking Requirements

Generally, redundant links are used to connect an Ethernet switching network to an upper-layer network to provide link backup and enhance network reliability. The use of redundant links, however, may produce loops, causing broadcast storms and rendering the MAC address table unstable. As a result, communication quality deteriorates, and services may even be interrupted. SEP can be deployed on the ring network to eliminate loops and restore communication if a link fault occurs.

In multi-ring networking, multiple rings consisting of Layer 2 switching devices are deployed at the access layer and aggregation layer. SEP runs at the access layer and aggregation layer to implement link redundancy.

In Figure 1, multiple Layer 2 switching devices form ring networks at the access layer and aggregation layer.

SEP runs at the access layer and aggregation layer. When there is no faulty link on a ring network, SEP can eliminate loops on the network. When a link fails on the ring network, SEP can rapidly restore communication between nodes on the network.

Figure 1 Networking diagram of a multi-ring SEP network

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic SEP functions.

    1. Configure SEP segments 1 to 3 and configure VLAN 10, VLAN 20, and VLAN 30 as their respective control VLANs.

      • Configure SEP segment 1 on LSW1 to LSW5 and configure VLAN 10 as the control VLAN of SEP segment 1.
      • Configure SEP segment 2 on LSW2, LSW3, and LSW6 to LSW8, and configure VLAN 20 as the control VLAN of SEP segment 2.

      • Configure SEP segment 3 on LSW3, LSW4, and LSW9 to LSW11, and configure VLAN 30 as the control VLAN of SEP segment 3.

    2. Add devices on the rings to the SEP segments and configure interface roles on the edge devices of the SEP segments.

      • On LSW1 to LSW5, add the interfaces on the ring at the access layer to SEP segment 1. Configure the roles of GE0/0/1 and GE0/0/3 of LSW1 in SEP segment 1.

      • Add GE0/0/2 of LSW2, GE0/0/1 and GE0/0/2 of LSW6 to LSW8, and GE0/0/2 of LSW3 to SEP segment 2. Configure the roles of GE0/0/2 of LSW2 and GE0/0/2 of LSW3 in SEP segment 2.

      • Add GE0/0/1 of LSW3, GE0/0/1 and GE0/0/2 of LSW9 to LSW11, and GE0/0/1 of LSW4 to SEP segment 3. Configure the roles of GE0/0/1 of LSW3 and GE0/0/1 of LSW4 in SEP segment 3.

    3. Specify an interface to block on the device where the primary edge interface is located.

      • In SEP segment 1, specify the interface with the highest priority to block.

      • In SEP segment 2, specify the device and interface names to block the specified interface.

      • In SEP segment 3, specify the blocked interface based on the configured hop count.

    4. Configure the preemption mode on the device where the primary edge interface is located.

      Configure delayed preemption in SEP segment 1 and manual preemption in SEP segment 2 and SEP segment 3.

    5. Configure the topology change notification function on the edge devices between SEP segments, namely, LSW2, LSW3, and LSW4.

  2. Configure the Layer 2 forwarding function on CE1, CE2, and LSW1 to LSW11.

Procedure

  1. Configure basic SEP functions.

    1. Configure SEP segments 1 to 3 and configure VLAN 10, VLAN 20, and VLAN 30 as their respective control VLANs, In Figure 1.

      # Configure LSW1.
      <HUAWEI> system-view
      [HUAWEI] sysname LSW1
      [LSW1] sep segment 1
      [LSW1-sep-segment1] control-vlan 10
      [LSW1-sep-segment1] protected-instance all
      [LSW1-sep-segment1] quit

      # Configure LSW2.

      <HUAWEI> system-view
      [HUAWEI] sysname LSW2
      [LSW2] sep segment 1
      [LSW2-sep-segment1] control-vlan 10
      [LSW2-sep-segment1] protected-instance all
      [LSW2-sep-segment1] quit
      [LSW2] sep segment 2
      [LSW2-sep-segment2] control-vlan 20
      [LSW2-sep-segment2] protected-instance all
      [LSW2-sep-segment2] quit

      # Configure LSW3.

      <HUAWEI> system-view
      [HUAWEI] sysname LSW3
      [LSW3] sep segment 1
      [LSW3-sep-segment1] control-vlan 10
      [LSW3-sep-segment1] protected-instance all
      [LSW3-sep-segment1] quit
      [LSW3] sep segment 2
      [LSW3-sep-segment2] control-vlan 20
      [LSW3-sep-segment2] protected-instance all
      [LSW3-sep-segment2] quit
      [LSW3] sep segment 3
      [LSW3-sep-segment3] control-vlan 30
      [LSW3-sep-segment3] protected-instance all
      [LSW3-sep-segment3] quit

      # Configure LSW4.

      <HUAWEI> system-view
      [HUAWEI] sysname LSW4
      [LSW4] sep segment 1
      [LSW4-sep-segment1] control-vlan 10
      [LSW4-sep-segment1] protected-instance all
      [LSW4-sep-segment1] quit
      [LSW4] sep segment 3
      [LSW4-sep-segment3] control-vlan 30
      [LSW4-sep-segment3] protected-instance all
      [LSW4-sep-segment3] quit
      # Configure LSW5.
      <HUAWEI> system-view
      [HUAWEI] sysname LSW5
      [LSW5] sep segment 1
      [LSW5-sep-segment1] control-vlan 10
      [LSW5-sep-segment1] protected-instance all
      [LSW5-sep-segment1] quit

      # Configure LSW6 to LSW11.

      The configurations of LSW6 to LSW11 are similar to the configurations of LSW1 to LSW5 except for the control VLANs of different SEP segments.

      For details about the configuration, see the configuration files.

      • The control VLAN must be a VLAN that has not been created or used, but the configuration file automatically displays the command for creating the VLAN.

      • Each SEP segment must be configured with a control VLAN. After an interface is added to a SEP segment configured with a control VLAN, the interface will be automatically added to the control VLAN.

    2. Add devices on the rings to the SEP segments and configure interface roles according to Figure 1.

      By default, STP is enabled on a Layer 2 interface. Before adding an interface to a SEP segment, disable STP on the interface.

      # On LSW1, configure GE0/0/1 as the primary edge interface and GE0/0/3 as the secondary edge interface.

      [LSW1] interface gigabitethernet 0/0/1
      [LSW1-GigabitEthernet0/0/1] port link-type hybrid
      [LSW1-GigabitEthernet0/0/1] stp disable
      [LSW1-GigabitEthernet0/0/1] sep segment 1 edge primary
      [LSW1-GigabitEthernet0/0/1] quit
      [LSW1] interface gigabitethernet 0/0/3
      [LSW1-GigabitEthernet0/0/3] port link-type hybrid
      [LSW1-GigabitEthernet0/0/3] stp disable
      [LSW1-GigabitEthernet0/0/3] sep segment 1 edge secondary
      [LSW1-GigabitEthernet0/0/3] quit

      # Configure LSW2.

      [LSW2] interface gigabitethernet 0/0/1
      [LSW2-GigabitEthernet0/0/1] port link-type hybrid
      [LSW2-GigabitEthernet0/0/1] stp disable
      [LSW2-GigabitEthernet0/0/1] sep segment 1
      [LSW2-GigabitEthernet0/0/1] quit
      [LSW2] interface gigabitethernet 0/0/3
      [LSW2-GigabitEthernet0/0/3] port link-type hybrid
      [LSW2-GigabitEthernet0/0/3] stp disable
      [LSW2-GigabitEthernet0/0/3] sep segment 1
      [LSW2-GigabitEthernet0/0/3] quit
      [LSW2] interface gigabitethernet 0/0/2
      [LSW2-GigabitEthernet0/0/2] port link-type hybrid
      [LSW2-GigabitEthernet0/0/2] stp disable
      [LSW2-GigabitEthernet0/0/2] sep segment 2 edge primary
      [LSW2-GigabitEthernet0/0/2] quit

      # Configure LSW3.

      [LSW3] interface gigabitethernet 0/0/3
      [LSW3-GigabitEthernet0/0/3] port link-type hybrid
      [LSW3-GigabitEthernet0/0/3] stp disable
      [LSW3-GigabitEthernet0/0/3] sep segment 1
      [LSW3-GigabitEthernet0/0/3] quit
      [LSW3] interface gigabitethernet 0/0/4
      [LSW3-GigabitEthernet0/0/4] port link-type hybrid
      [LSW3-GigabitEthernet0/0/4] stp disable
      [LSW3-GigabitEthernet0/0/4] sep segment 1
      [LSW3-GigabitEthernet0/0/4] quit
      [LSW3] interface gigabitethernet 0/0/2
      [LSW3-GigabitEthernet0/0/2] port link-type hybrid
      [LSW3-GigabitEthernet0/0/2] stp disable
      [LSW3-GigabitEthernet0/0/2] sep segment 2 edge secondary
      [LSW3-GigabitEthernet0/0/2] quit
      [LSW3] interface gigabitethernet 0/0/1
      [LSW3-GigabitEthernet0/0/1] port link-type hybrid
      [LSW3-GigabitEthernet0/0/1] stp disable
      [LSW3-GigabitEthernet0/0/1] sep segment 3 edge secondary
      [LSW3-GigabitEthernet0/0/1] quit

      # Configure LSW4.

      [LSW4] interface gigabitethernet 0/0/2
      [LSW4-GigabitEthernet0/0/2] port link-type hybrid
      [LSW4-GigabitEthernet0/0/2] stp disable
      [LSW4-GigabitEthernet0/0/2] sep segment 1
      [LSW4-GigabitEthernet0/0/2] quit
      [LSW4] interface gigabitethernet 0/0/3
      [LSW4-GigabitEthernet0/0/3] port link-type hybrid
      [LSW4-GigabitEthernet0/0/3] stp disable
      [LSW4-GigabitEthernet0/0/3] sep segment 1
      [LSW4-GigabitEthernet0/0/3] quit
      [LSW4] interface gigabitethernet 0/0/1
      [LSW4-GigabitEthernet0/0/1] port link-type hybrid
      [LSW4-GigabitEthernet0/0/1] stp disable
      [LSW4-GigabitEthernet0/0/1] sep segment 3 edge primary
      [LSW4-GigabitEthernet0/0/1] quit

      # Configure LSW5.

      [LSW5] interface gigabitethernet 0/0/1
      [LSW5-GigabitEthernet0/0/1] port link-type hybrid
      [LSW5-GigabitEthernet0/0/1] stp disable
      [LSW5-GigabitEthernet0/0/1] sep segment 1
      [LSW5-GigabitEthernet0/0/1] quit
      [LSW5] interface gigabitethernet 0/0/3
      [LSW5-GigabitEthernet0/0/3] port link-type hybrid
      [LSW5-GigabitEthernet0/0/3] stp disable
      [LSW5-GigabitEthernet0/0/3] sep segment 1
      [LSW5-GigabitEthernet0/0/3] quit

      # Configure LSW6 to LSW11.

      The configurations of LSW6 to LSW11 are similar to the configurations of LSW1 to LSW5 except for the interface roles.

      For details about the configuration, see the configuration files.

    3. Specify an interface to block.

      # On LSW1 where the primary edge interface of SEP segment 1 is located, specify the interface with the highest priority to block.

      [LSW1] sep segment 1
      [LSW1-sep-segment1] block port optimal
      [LSW1-sep-segment1] quit

      # On LSW3, set the priority of GE0/0/4 to 128, which is the highest priority among the interfaces so that GE0/0/4 will be blocked.

      [LSW3] interface gigabitethernet 0/0/4
      [LSW3-GigabitEthernet0/0/4] sep segment 1 priority 128
      [LSW3-GigabitEthernet0/0/4] quit

      Retain the default priority of the other interfaces in SEP segment 1.

      # On LSW2 where the primary edge interface of SPE segment 2 is located, specify the device and interface names so that the specified interface will be blocked.

      Before specifying the interface to block, use the display sep topology command to view the current topology information and obtain information about all the interfaces in the topology. Then specify the device and interface names.

      [LSW2] sep segment 2
      [LSW2-sep-segment2] block port sysname LSW7 interface gigabitethernet 0/0/1
      [LSW2-sep-segment2] quit

      # On LSW4 where the primary edge interface of SEP segment 3 is located, specify the blocked interface based on the configured hop count.

      [LSW4] sep segment 3
      [LSW4-sep-segment3] block port hop 5
      [LSW4-sep-segment3] quit

      SEP sets the hop count of the primary edge interface to 1 and the hop count of the secondary edge interface to 2. Hop counts of other interfaces increase by steps of 1 in the downstream direction of the primary interface.

    4. Configure the preemption mode.

      # Configure delayed preemption on LSW1.

      [LSW1] sep segment 1
      [LSW1-sep-segment1] preempt delay 30
      • You must set the preemption delay when delayed preemption is used because there is no default delay time.

      • When the last faulty interface recovers, edge interfaces do not receive any fault notification packet. If the primary edge interface does not receive any fault notification packet, it starts the delay timer. After the delay timer expires, nodes in the SEP segment start blocked interface preemption.

        To implement delayed preemption in this example, simulate a port fault and then rectify the fault. For example:

        Run the shutdown command on GE0/0/2 of LSW2 to simulate an interface fault, and then run the undo shutdown command on GE0/0/2 to rectify the fault.

      # Configure manual preemption on LSW2.

      [LSW2] sep segment 2
      [LSW2-sep-segment2] preempt manual

      # Configure the manual preemption mode on LSW4.

      [LSW4] sep segment 3
      [LSW4-sep-segment3] preempt manual
    5. Configure the topology change notification function.

      # Configure devices in SEP segment 2 to notify SEP segment 1 of topology changes.

      # Configure LSW2.

      [LSW2] sep segment 2
      [LSW2-sep-segment2] tc-notify segment 1
      [LSW2-sep-segment2] quit

      # Configure LSW3.

      [LSW3] sep segment 2
      [LSW3-sep-segment2] tc-notify segment 1
      [LSW3-sep-segment2] quit

      # Configure SEP segment 3 to notify SEP segment 1 of topology changes.

      # Configure LSW3.

      [LSW3] sep segment 3
      [LSW3-sep-segment3] tc-notify segment 1
      [LSW3-sep-segment3] quit

      # Configure LSW4.

      [LSW4] sep segment 3
      [LSW4-sep-segment3] tc-notify segment 1
      [LSW4-sep-segment3] quit

      The topology change notification function is configured on edge devices between SEP segments so that the upper-layer network can be notified of topology changes on the lower-layer network.

  2. Configure the Layer 2 forwarding function on the CEs and LSW1 to LSW11.

    For details about the configuration, see the configuration files.

  3. Verify the configuration.

    After completing the preceding configurations, verify the configuration. LSW1 is used as an example.

    • Run the shutdown command on GE0/0/1 of LSW2 to simulate an interface fault, and then run the display sep interface command on LSW3 to check whether GE0/0/4 of LSW3 has switched from the Discarding state to the Forwarding state.

      <LSW3> display sep interface gigabitethernet 0/0/4
      SEP segment 1
      ----------------------------------------------------------------
      Interface           Port Role     Neighbor Status     Port Status
      ----------------------------------------------------------------
      GE0/0/4             common        up                  forwarding  

Configuration Files

  • LSW1 configuration file

    #
     sysname LSW1
    #
     vlan batch 10 100 200 300
    #
    sep segment 1
     control-vlan 10
     block port optimal
     preempt delay 30
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100 200
     stp disable
     sep segment 1 edge primary
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 300
     port hybrid tagged vlan 100 200
     port hybrid untagged vlan 300
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid tagged vlan 10 100 200 300
     stp disable
     sep segment 1 edge secondary
    #
    return
  • LSW2 configuration file

    #
     sysname LSW2
    #
     vlan batch 10 20 100 200
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 48
    sep segment 2
     control-vlan 20
     block port sysname LSW7 interface GigabitEthernet0/0/1
     tc-notify segment 1
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100 200
     stp disable
     sep segment 1
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid tagged vlan 20 200
     stp disable
     sep segment 2 edge primary
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid tagged vlan 10 100 200
     stp disable
     sep segment 1
    #
    return
  • LSW3 configuration file

    #
     sysname LSW3
    #
     vlan batch 10 20 30 100 200
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 48
    sep segment 2
     control-vlan 20
     tc-notify segment 1
     protected-instance 0 to 48
    sep segment 3
     control-vlan 30
     tc-notify segment 1
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 30 100
     stp disable
     sep segment 3 edge secondary
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid tagged vlan 20 200
     stp disable
     sep segment 2 edge secondary
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid tagged vlan 10 100 200
     stp disable
     sep segment 1
    #
    interface GigabitEthernet0/0/4
     port link-type hybrid
     port hybrid tagged vlan 10 100 200
     stp disable
     sep segment 1
     sep segment 1 priority 128
    #
    return
  • LSW4 configuration file

    #
     sysname LSW4
    #
     vlan batch 10 30 100 200
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 48
    sep segment 3
     control-vlan 30
     block port hop 5
     tc-notify segment 1
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 30 100
     stp disable
     sep segment 3 edge primary
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid tagged vlan 10 100 200
     stp disable
     sep segment 1
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid tagged vlan 10 100 200
     stp disable
     sep segment 1
    #
    return
  • LSW5 configuration file

    #
     sysname LSW5
    #
     vlan batch 10 100 200 300
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100 200
     stp disable
     sep segment 1
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 300
     port hybrid tagged vlan 100 200
     port hybrid untagged vlan 300
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid tagged vlan 10 100 200 300
     stp disable
     sep segment 1
    #
    return
  • LSW6 configuration file

    #
     sysname LSW6
    #
     vlan batch 20 200
    #
    sep segment 2
     control-vlan 20
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 20 200
     stp disable
     sep segment 2
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid tagged vlan 20 200
     stp disable
     sep segment 2
    #
    return
  • LSW7 configuration file

    #
     sysname LSW7
    #
     vlan batch 20 200
    #
    sep segment 2
     control-vlan 20
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 20 200
     stp disable
     sep segment 2
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid tagged vlan 20 200
     stp disable
     sep segment 2
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid tagged vlan 200
    #
    return
  • LSW8 configuration file

    #
     sysname LSW8
    #
     vlan batch 20 200
    #
    sep segment 2
     control-vlan 20
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 20 200
     stp disable
     sep segment 2
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid tagged vlan 20 200
     stp disable
     sep segment 2
    #
    return
  • LSW9 configuration file

    #
     sysname LSW9
    #
     vlan batch 30 100
    #
    sep segment 3
     control-vlan 30
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 30 100
     stp disable
     sep segment 3
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid tagged vlan 30 100
     stp disable
     sep segment 3
    #
    return                 
  • LSW10 configuration file

    #
     sysname LSW10
    #
     vlan batch 30 100
    #
    sep segment 3
     control-vlan 30
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 30 100
     stp disable
     sep segment 3
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid tagged vlan 30 100
     stp disable
     sep segment 3
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    return
  • LSW11 configuration file

    #
     sysname LSW11
    #
     vlan batch 30 100
    #
    sep segment 3
     control-vlan 30
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 30 100
     stp disable
     sep segment 3
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid tagged vlan 30 100
     stp disable
     sep segment 3
    #
    return
  • CE1 configuration file

    #
     sysname CE1
    #
     vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    return
  • CE2 configuration file

    #
     sysname CE2
    #
     vlan batch 200
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid tagged vlan 200
    #
    return

Related Content

Videos

Configuring SEP

Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >