< Home

Example for Configuring Flexible Flow Statistics Exporting

NetStream Overview

NetStream is a technology that collects statistics on and analyzes service traffic on networks. NetStream facilitates accounting and network monitoring.

It has the following advantages:

  • NetStream collects statistics on multiple types of information in packets. It provides powerful statistics collection function and detailed statistical results.
  • NetStream can be deployed at a low cost. No dedicated device is required to collect traffic information and no device interface is occupied.

In flexible flow statistics exporting, flows are set based on customized rules. You can customize flows based on the protocol type, DSCP priority, source IP address, destination IP address, source port number, destination port number, or flow label as required. Flexible flow statistics are sent to the NetStream server. Compared with original flow statistics collection, flexible flow statistics collection occupies less traffic and is more flexible.

Configuration Notes

NetStream conflicts with IP Source Trail on modular switches, so do not configure them simultaneously.

For the applicable product models and versions of this example, see Applicable product models and versions.

Networking Requirements

As shown in Figure 1, Department 1 and Department 2 connect to the Internet through SwitchA. Network administrators want to monitor communication between the two departments and the Internet.

Figure 1 Networking diagram for configuring flexible flow statistics exporting

Configuration Roadmap

You can configure IPv4 flexible flow statistics exporting on GE1/0/1 of SwitchA. Configure SwitchA to collect statistics on incoming and outgoing traffic on the interface, and to send the statistics to the NetStream server for further analysis. In this way, you can monitor communication between the two departments and the Internet.

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces on SwitchA.
  2. Configure a flexible flow statistics template.
  3. Configure NetStream flexible flow statistics exporting.
  4. Enable flexible flow statistics collection on GE1/0/1.

Procedure

  1. Configure IP addresses for interfaces on SwitchA according to Figure 1.

    # Configure IP addresses for interfaces on SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 200 300 400
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface vlanif 200
    [SwitchA-Vlanif200] ip address 10.1.2.1 24
    [SwitchA-Vlanif200] quit
    [SwitchA] interface vlanif 300
    [SwitchA-Vlanif300] ip address 10.1.3.1 24
    [SwitchA-Vlanif300] quit
    [SwitchA] interface vlanif 400
    [SwitchA-Vlanif400] ip address 10.1.4.1 24
    [SwitchA-Vlanif400] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100 
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 200 
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 300 
    [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 300
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/4] port hybrid pvid vlan 400 
    [SwitchA-GigabitEthernet1/0/4] port hybrid untagged vlan 400
    [SwitchA-GigabitEthernet1/0/4] quit

  2. Configure a flexible flow statistics template.

    # Create a flexible flow statistics template test to aggregate flows based on the destination IP address and destination port number, and configure the exported packets to contain the number of bytes and packets and the indexes of the inbound and outbound interfaces.

    [SwitchA] ip netstream record test
    [SwitchA-record-test] match ip destination-address
    [SwitchA-record-test] match ip destination-port
    [SwitchA-record-test] collect interface input
    [SwitchA-record-test] collect interface output
    [SwitchA-record-test] collect counter bytes
    [SwitchA-record-test] collect counter packets
    [SwitchA-record-test] quit

  3. Configure NetStream flexible flow statistics exporting.

    # Set the source IP address of the exported packets carrying flexible flow statistics to 10.1.2.1, destination IP address to 10.1.2.2, and destination port number to 6000.

    [SwitchA] ip netstream export source 10.1.2.1
    [SwitchA] ip netstream export host 10.1.2.2 6000

  4. Enable flexible flow statistics collection on GE1/0/1.

    # Enable flexible flow statistics collection on GE1/0/1, and apply the flexible flow statistics template test to GE1/0/1.

    [SwitchA] interface gigabitEthernet 1/0/1 
    [SwitchA-GigabitEthernet1/0/1] port ip netstream record test
    [SwitchA-GigabitEthernet1/0/1] ip netstream inbound
    [SwitchA-GigabitEthernet1/0/1] ip netstream outbound
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] quit

  5. Verify the configuration.

    # After the configuration is complete, the NetStream server can receive statistics packets from SwitchA. Run the display ip netstream statistics command on SwitchA to view NetStream flow statistics.

    <SwitchA> display ip netstream statistics slot 1
     ===== Netstream statistics: =====
     Origin/Flexible ingress entries  : 20
     Origin/Flexible ingress packets  : 176541
     Origin/Flexible ingress octets   : 123657230
     Origin/Flexible egress entries   : 0
     Origin/Flexible egress packets   : 0
     Origin/Flexible egress octets    : 0
     Origin/Flexible total entries    : 20
     Handle origin entries            : 0
     Handle As aggre entries          : 0
     Handle ProtPort aggre entries    : 0
     Handle SrcPrefix aggre entries   : 0
     Handle DstPrefix aggre entries   : 0
     Handle Prefix aggre entries      : 0
     Handle AsTos aggre entries       : 0
     Handle ProtPortTos aggre entries : 0
     Handle SrcPreTos aggre entries   : 0
     Handle DstPreTos aggre entries   : 0
     Handle PreTos aggre entries      : 0
     Record test handle entries : 10

Configuration Files

Configuration file of SwitchA

#                                                                               
sysname SwitchA 
#                                                                               
vlan batch 100 200 300 400 
#
ip netstream export source 10.1.2.1
ip netstream export host 10.1.2.2 6000
#
ip netstream record test
 match ip destination-address
 match ip destination-port
 collect counter packets
 collect counter bytes
 collect interface input
 collect interface output
#                                                                               
interface Vlanif100                                                             
 ip address 10.1.1.1 255.255.255.0 
#                                                                               
interface Vlanif200                                                             
 ip address 10.1.2.1 255.255.255.0 
#                                                                               
interface Vlanif300                                                             
 ip address 10.1.3.1 255.255.255.0 
#                                                                               
interface Vlanif400                                                             
 ip address 10.1.4.1 255.255.255.0 
#                                                                               
interface GigabitEthernet1/0/1                                                  
 port link-type hybrid
 port hybrid pvid vlan 100                                                      
 port hybrid untagged vlan 100  
 ip netstream inbound
 ip netstream outbound
 port ip netstream record test
#                                                                               
interface GigabitEthernet1/0/2                                                  
 port link-type hybrid
 port hybrid pvid vlan 200                                                      
 port hybrid untagged vlan 200  
#                                                                               
interface GigabitEthernet1/0/3                                                  
 port link-type hybrid
 port hybrid pvid vlan 300                                                      
 port hybrid untagged vlan 300  
#                                                                               
interface GigabitEthernet1/0/4                                                  
 port link-type hybrid
 port hybrid pvid vlan 400                                                      
 port hybrid untagged vlan 400  
#
return

Applicable product models and versions

Product

Product Model

Software Version

S5700

S5700-HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00SPC500&C01&C02)

S5710-EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5710-HI

V200R003C00, V200R005(C00&C02&C03)

S5720-HI

V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00, V200R019C00, V200R019C10

S5730-HI

V200R012C00, V200R013C00, V200R019C00, V200R019C10

S5731-H

V200R013C02, V200R019C00, V200R019C10

S5731-S, S5731S-S

V200R019C00, V200R019C10

S5731S-H

V200R019C00, V200R019C10

S5732-H

V200R019C00, V200R019C10

S7700

S7703, S7706, S7712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00, V200R013C02, V200R019C00, V200R019C10

S7703 PoE

V200R013C00, V200R019C00, V200R019C10

S7706 PoE

V200R013C00, V200R019C00, V200R019C10

S9700

S9703, S9706, S9712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00

S6700

S6720-HI

V200R012C00, V200R013C00, V200R019C00, V200R019C10

S6730-H

V200R013C02, V200R019C00, V200R019C10

S6730S-H

V200R019C10

S6730-S, S6730S-S

V200R019C00, V200R019C10

For S7700&S9700 series switches, NetStream is only supported by B series cards, E series cards (except ET1D2X48SEC0 card and EH1D2X48SEC0 card), and X series cards.

Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic