This section provides an example for configuring frame loss measurement (LM) for a bidirectional label switched path (LSP).
As a connection-oriented packet switching technology, Multiprotocol Label Switching Transport Profile (MPLS-TP) is designed to convert a circuit switched transport network to a packet switched transport network. The purpose is to increase the transmission rate on the transport network.
The frame loss ratio is the ratio of lost frames to the frames sent during a specified period in percentage terms. The number of lost frames is the difference between the number of frames sent by the ingress and the number of frames received by the egress on a point-to-point LSP.
Frame LM can be used to collect frame loss statistics and evaluate link performance. LM is a performance monitoring function provided by MPLS-TP and is classified as single-ended frame LM or dual-ended frame LM.
The configuration of dual-ended frame LM is used as an example in this section. Regardless of single-ended or dual-ended, DM configurations on PEs are the same except the statistics display configurations.
On the network shown in Figure 1, a bidirectional LSP is established to connect label switching routers (LSRs) A, B, and C. The following deployment is made to ensure the connectivity between LSRA and LSRC:
Interfaces 1 through 2 in this example are GE 0/1/0 and GE 0/1/8, respectively.
Device |
Interface |
IP Address |
---|---|---|
LSRA |
Loopback1 |
1.1.1.1/32 |
GigabitEthernet0/1/0 |
2.1.1.1/24 |
|
LSRB |
Loopback1 |
2.2.2.2/32 |
GigabitEthernet0/1/0 |
2.1.1.2/24 |
|
GigabitEthernet0/1/8 |
3.2.1.1/24 |
|
LSRC |
Loopback1 |
3.3.3.3/32 |
GigabitEthernet0/1/8 |
3.2.1.2/24 |
The configuration roadmap is as follows:
Create a maintenance entity (ME) instance and bind it to a bidirectional LSP.
Enable continuity check (CC) and connectivity verification (CV) on the MEP and its remote MEP (RMEP).
Configure an alarm threshold for lost frames.
Enable dual-ended frame LM.
To complete the configuration, you need the following data:
MEG name
Name of the tunnel interface to which an ME instance is bound
Alarm threshold for lost frames
For configuration details, see "Example for Configuring a Static Bidirectional Co-routed CR-LSP" in HUAWEI NetEngine 8000 F SeriesRouter Configuration Guide - MPLS or "Configuration Files" in this section.
[~LSRA] mpls-tp meg test [~LSRA-mpls-tp-meg-test] me te interface Tunnel 10 mep-id 1 remote-mep-id 2 [*LSRA-mpls-tp-meg-test] commit
[~LSRC] mpls-tp meg test [~LSRC-mpls-tp-meg-test] me te interface Tunnel 20 mep-id 2 remote-mep-id 1 [*LSRC-mpls-tp-meg-test] commit
The same interval at which CCMs are sent and priority of CCMs must be configured on the MEP and RMEP. If the configurations at both ends are different, an alarm indicating an error is reported.
[~LSRA-mpls-tp-meg-test] cc interval 100 [*LSRA-mpls-tp-meg-test] cc exp 6 [*LSRA-mpls-tp-meg-test] commit
[~LSRC-mpls-tp-meg-test] cc interval 100 [*LSRC-mpls-tp-meg-test] cc exp 6 [*LSRA-mpls-tp-meg-test] commit
[~LSRA-mpls-tp-meg-test] cc send enable [*LSRA-mpls-tp-meg-test] cc receive enable [LSRA-mpls-tp-meg-test] return
[~LSRC-mpls-tp-meg-test] cc send enable [*LSRC-mpls-tp-meg-test] cc receive enable [*LSRA-mpls-tp-meg-test] commit
[~LSRA-mpls-tp-meg-test] lost-measure dual-ended enable [*LSRA-mpls-tp-meg-test] commit
[~LSRC-mpls-tp-meg-test] lost-measure dual-ended enable [*LSRC-mpls-tp-meg-test] commit
After completing the configurations, run the display mpls-tp oam command on LSRA to view frame loss statistics.
<LSRA> display mpls-tp oam meg test statistic-type lost-measure dual-ended Dual-end loss measurement statistics: Index Near-end lost frames Loss ratio Far-end lost frames Loss ratio 1 10 12.50% 10 12.50% Max near-end lost frames:10,frame loss ratio:12.50% Min near-end lost frames:10,frame loss ratio:12.50% Average near-end lost frames:10,frame loss ratio:12.50% Max far-end lost frames:10,frame loss ratio:12.50% Min far-end lost frames:10,frame loss ratio:12.50% Average far-end lost frames:10,frame loss ratio:12.50%
LSRA configuration file
#
sysname LSRA
#
mpls lsr-id 1.1.1.1
mpls
mpls te
#
bidirectional static-cr-lsp ingress Tunnel10
forward nexthop 2.1.1.2 out-label 20
backward in-label 20
#
interface GigabitEthernet0/1/0
undo shutdown
ip address 2.1.1.1 255.255.255.0
mpls
mpls te
#
interface LoopBack1
ip address 1.1.1.1 255.255.255.255
#
interface Tunnel10
ip address unnumbered interface LoopBack1
tunnel-protocol mpls te
destination 3.3.3.3
mpls te signal-protocol cr-static
mpls te tunnel-id 100
mpls te bidirectional
#
ip route-static 2.2.2.2 255.255.255.255 2.1.1.2
ip route-static 3.3.3.3 255.255.255.255 2.1.1.2
#
mpls-tp meg test
me te interface Tunnel10 mep-id 1 remote-mep-id 2
cc send enable
cc receive enable
lost-measure dual-ended enable
#
return
LSRB configuration file
# sysname LSRB # mpls lsr-id 2.2.2.2 mpls mpls te # bidirectional static-cr-lsp transit lsp1 forward in-label 20 nexthop 3.2.1.2 out-label 40 backward in-label 16 nexthop 2.1.1.1 out-label 20 # interface GigabitEthernet0/1/0 undo shutdown ip address 2.1.1.2 255.255.255.0 mpls mpls te # interface GigabitEthernet0/1/8 undo shutdown ip address 3.2.1.1 255.255.255.0 mpls mpls te # interface LoopBack1 ip address 2.2.2.2 255.255.255.255 # ip route-static 1.1.1.1 255.255.255.255 2.1.1.1 ip route-static 3.3.3.3 255.255.255.255 3.2.1.2 # return
LSRC configuration file
#
sysname LSRC
#
mpls lsr-id 3.3.3.3
mpls
mpls te
#
bidirectional static-cr-lsp egress lsp1
forward in-label 40 lsrid 1.1.1.1 tunnel-id 100
backward nexthop 3.2.1.1 out-label 16
#
interface GigabitEthernet0/1/0
undo shutdown
ip address 3.2.1.2 255.255.255.0
mpls
mpls te
#
interface LoopBack1
ip address 3.3.3.3 255.255.255.255
#
interface Tunnel20
ip address unnumbered interface LoopBack1
tunnel-protocol mpls te
destination 1.1.1.1
mpls te signal-protocol cr-static
mpls te tunnel-id 200
mpls te passive-tunnel
mpls te binding bidirectional static-cr-lsp egress lsp1
#
ip route-static 1.1.1.1 255.255.255.255 3.2.1.1
ip route-static 2.2.2.2 255.255.255.255 3.2.1.1
#
mpls-tp meg test
me te interface Tunnel20 mep-id 2 remote-mep-id 1
cc send enable
cc receive enable
lost-measure dual-ended enable
#
return