Example for Configuring a Generalflow Test in a Native Ethernet Scenario (RFC 2544)

This section describes how to configure a generalflow test in a native Ethernet scenario. A generalflow test is used to monitor the native Ethernet network performance.

Networking Requirements

A generalflow test needs to be configured to monitor the performance of an Ethernet virtual connection (EVC) between Device A and Device B on the network shown in Figure 1.

Figure 1 General flow test in a native Ethernet scenario

Interfaces 1 and 2 in this example are GE0/1/1, and GE0/1/2, respectively.


Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure reflector Device B to loop traffic with a specified destination MAC address through reflector interface GE 0/1/1 to the initiator.
  2. Configure initiator Device A and test the throughput, latency, and packet loss rate.
  3. Configure Device C's interface to join the specified VLAN.

Data Preparation

To complete the configuration, you need the following data:

  • On reflector Device B: MAC address (00-e0-fc-12-34-56) of the interface directly connected to UNI-B
  • On initiator Device A:

    • Destination MAC address (00-e0-fc-12-34-56) of the interface directly connected to UNI-B
    • Throughput test parameters: upper rate threshold (100000 Kbit/s), lower rate threshold (10000 Kbit/s), throughput precision (1000 Kbit/s), packet loss rate (81), interval (5s) at which test packets are transmitted at a specified rate, data size (70 bytes) of each test packet, and test duration (100s)
    • Delay test parameters: packet rate (99000 Kbit/s), test duration (100s), and interval (5s) at which the initiator sends test packets
    • Packet loss rate test parameters: packet rate (99000 Kbit/s), and test duration (100s)

Procedure

  1. Configure reachable Layer 2 links between the initiator and reflector and add Layer 2 interfaces to VLAN 10. For configuration details, see "Configuration Files" in this section.
  2. Configure the reflector.

    <DeviceB> system-view
    [~DeviceB] nqa reflector 1 interface gigabitethernet 0/1/1 mac 00-e0-fc-12-34-56 vlan 10

  3. Configure the initiator to conduct a throughput test and check the test results.

    <DeviceA> system-view
    [~DeviceA] nqa test-instance admin throughput
    [*DeviceA-nqa-admin-throughput] test-type generalflow
    [*DeviceA-nqa-admin-throughput] measure throughput
    [*DeviceA-nqa-admin-throughput] destination-address mac 00-e0-fc-12-34-56
    [*DeviceA-nqa-admin-throughput] forwarding-simulation inbound-interface gigabitethernet 0/1/1
    [*DeviceA-nqa-admin-throughput] rate 10000 100000
    [*DeviceA-nqa-admin-throughput] interval seconds 5
    [*DeviceA-nqa-admin-throughput] precision 1000
    [*DeviceA-nqa-admin-throughput] fail-ratio 81
    [*DeviceA-nqa-admin-throughput] datasize 70
    [*DeviceA-nqa-admin-throughput] duration 100
    [*DeviceA-nqa-admin-throughput] vlan 10
    [*DeviceA-nqa-admin-throughput] start now
    [*DeviceA-nqa-admin-throughput] commit
    [~DeviceA-nqa-admin-throughput] display nqa results test-instance admin throughput
    NQA entry(admin, throughput) :testflag is inactive ,testtype is generalflow
      1 . Test 1 result: The test is finished, test mode is throughput
       ID Size Throughput(Kbps) Precision(Kbps) LossRatio Completion
       1  70   100000            1000            0.00%     success   

  4. Configure the initiator to conduct a latency test and check the test results.

    [*DeviceA] nqa test-instance admin delay
    [*DeviceA-nqa-admin-delay] test-type generalflow
    [*DeviceA-nqa-admin-delay] measure delay
    [*DeviceA-nqa-admin-delay] destination-address mac 00-e0-fc-12-34-56
    [*DeviceA-nqa-admin-delay] forwarding-simulation inbound-interface gigabitethernet 0/1/1
    [*DeviceA-nqa-admin-delay] datasize 64
    [*DeviceA-nqa-admin-delay] rate 99000
    [*DeviceA-nqa-admin-delay] interval seconds 5
    [*DeviceA-nqa-admin-delay] duration 100
    [*DeviceA-nqa-admin-delay] vlan 10
    [*DeviceA-nqa-admin-delay] start now
    [*DeviceA-nqa-admin-delay] commit
    [~DeviceA-nqa-admin-delay] display nqa results test-instance admin delay
    NQA entry(admin, delay) :testflag is inactive ,testtype is generalflow
      1 . Test 1 result: The test is finished, test mode is delay
       ID Size Min/Max/Avg RTT(us)     Min/Max/Avg Jitter(us)  Completion
       1  64   1/12/5                  2/15/8                   finished  

  5. Configure the initiator to conduct a packet loss rate test and check the test results.

    [*DeviceA] nqa test-instance admin loss
    [*DeviceA-nqa-admin-loss] test-type generalflow
    [*DeviceA-nqa-admin-loss] measure loss
    [*DeviceA-nqa-admin-loss] destination-address mac 00-e0-fc-12-34-56
    [*DeviceA-nqa-admin-loss] forwarding-simulation inbound-interface gigabitethernet 0/1/1
    [*DeviceA-nqa-admin-loss] datasize 64
    [*DeviceA-nqa-admin-loss] rate 99000
    [*DeviceA-nqa-admin-loss] duration 100
    [*DeviceA-nqa-admin-loss] vlan 10
    [*DeviceA-nqa-admin-loss] start now
    [*DeviceA-nqa-admin-loss] commit
    [~DeviceA-nqa-admin-loss] display nqa results test-instance admin loss
    NQA entry(admin, loss) :testflag is inactive ,testtype is generalflow
      1 . Test 1 result: The test is finished, test mode is loss
       ID Size TxRate/RxRate(Kbps) TxCount/RxCount             LossRatio Completion
       1  64   99000/99000         653265345/653265345         0.00%     finished  

Configuration Files

  • Configuration file of Device A

    #
    sysname DeviceA
    # 
    vlan 10
    #
    interface GigabitEthernet 0/1/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 0/1/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    nqa test-instance admin throughput
     test-type generalflow
     duration 100
     measure throughput
     fail-ratio 81
     destination-address mac 00e0-fc12-3456
     datasize 70
     rate 10000 100000
     precision 1000
     forwarding-simulation inbound-interface GigabitEthernet0/1/1
     vlan 10
    nqa test-instance admin loss
     test-type generalflow
     duration 100
     measure loss
     destination-address mac 00e0-fc12-3456
     datasize 64
     rate 99000
     forwarding-simulation inbound-interface GigabitEthernet0/1/1
     vlan 10
    nqa test-instance admin delay
     test-type generalflow
     duration 100
     measure delay
     interval seconds 5
     destination-address mac 00e0-fc12-3456
     datasize 64
     rate 99000
     forwarding-simulation inbound-interface GigabitEthernet0/1/1
     vlan 10
    #
    return
  • Configuration file of Device B

    #
    sysname DeviceB
    # 
    vlan 10
    nqa reflector 1 interface gigabitethernet 0/1/1 mac 00e0-fc12-3456 vlan 10
    #
    interface GigabitEthernet 0/1/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 0/1/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of Device C

    #
    sysname DeviceC
    # 
    vlan 10
    #
    interface GigabitEthernet 0/1/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 0/1/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >