Example for Configuring a Generalflow Test in the IP Gateway Scenario (RFC 2544)

This section describes how to configure a generalflow test in the IP gateway scenario. The generalflow test monitors the Ethernet network performance.

Usage Scenario

A generalflow test needs to be configured to monitor the performance of the Ethernet network shown in Figure 1 between Device A and IP gateway Device B.

Figure 1 General flow test in the IP gateway scenario

Interfaces 1 through 2 in this example are GE0/1/1, and GE0/1/2, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure reflector Device A.
  2. Configure initiator Device B and monitor the latency time.

Data Preparation

To complete the configuration, you need the following data:

  • On reflector Device A: Set the simulated IP address to 10.1.1.1 (CE's IP address) and the reflector interface to GE 0/1/1.
  • On initiator Device B:

    • Destination IP address: (10.1.1.1) of the CE connected to Device A's GE 0/1/1
    • Source IP address: an address that resides on the same network segment as the IP address of the initiator
    • Latency test parameters: packet rate (99000 Kbit/s), packet loss ratio (81%), test duration (100s), and interval (5s) at which the initiator sends test packets

Procedure

  1. Configure Layer 2 devices so that Layer 3 routes between the CE and Device B are reachable. For configuration details, see "Configuration Files" in this section.
  2. Configure the reflector.

    [*DeviceA] vlan 10
    [*DeviceA-vlan10] commit
    [~DeviceA-vlan10] quit
    [~DeviceA] nqa reflector 1 interface GigabitEthernet 0/1/1 ipv4 10.1.1.1 vlan 10 
    [*DeviceA] commit

  3. Configure the initiator to conduct a latency test and view test results.

    [*DeviceB] vlan 10
    [*DeviceB-vlan10] commit
    [~DeviceB-vlan10] quit
    [~DeviceB] interface gigabitethernet 0/1/2.1
    [*DeviceB-GigabitEthernet0/1/2.1] vlan-type dot1q 10
    [*DeviceB-GigabitEthernet0/1/2.1] ip address 10.1.1.2 24
    [*DeviceB-GigabitEthernet0/1/2.1] quit
    [*DeviceB] arp static 10.1.1.1 00e0-fc12-3456 vid 10 interface GigabitEthernet 0/1/2.1
    [*DeviceB] nqa test-instance admin delay
    [*DeviceB-nqa-admin-delay] test-type generalflow
    [*DeviceB-nqa-admin-delay] measure delay
    [*DeviceB-nqa-admin-delay] destination-address ipv4 10.1.1.1
    [*DeviceB-nqa-admin-delay] source-address ipv4 10.1.1.2
    [*DeviceB-nqa-admin-delay] source-interface gigabitethernet 0/1/2.1
    [*DeviceB-nqa-admin-delay] rate 99000
    [*DeviceB-nqa-admin-delay] interval seconds 5
    [*DeviceB-nqa-admin-delay] datasize 64
    [*DeviceB-nqa-admin-delay] duration 100
    [*DeviceB-nqa-admin-delay] start now
    [*DeviceB-nqa-admin-delay] commit
    [~DeviceB-nqa-admin-delay] display nqa results test-instance admin delay
    NQA entry(admin, delay) :testflag is inactive ,testtype is generalflow
      1 . Test 1 result: The test is finished, test mode is delay
       ID Size Min/Max/Avg RTT(us)     Min/Max/Avg Jitter(us)  Completion
       1  64   1/12/5                  2/15/8                   finished  

Configuration Files

  • Configuration file of Device A

    #
    sysname DeviceA
    # 
    vlan 10
    #
    nqa reflector 1 interface GigabitEthernet 0/1/1 ipv4 10.1.1.1 vlan 10
    #
    interface GigabitEthernet 0/1/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 0/1/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of Device B

    #
    sysname DeviceB
    #
    vlan 10
    #
    interface GigabitEthernet 0/1/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 0/1/2.1
     vlan-type dot1q 10
     ip address 10.1.1.2 255.255.255.0
    #
    arp static 10.1.1.1 00e0-fc12-3456 vid 10 interface GigabitEthernet 0/1/2.1
    nqa test-instance admin delay
     test-type generalflow
     destination-address ipv4 10.1.1.1
     source-address ipv4 10.1.1.2
     duration 100
     measure delay
     interval seconds 5
     datasize 64
     rate 99000
     source-interface GigabitEthernet 0/1/2.1
    #
    return
  • Configuration file of Device C

    #
    sysname DeviceC
    # 
    vlan 10
    #
    interface GigabitEthernet 0/1/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 0/1/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >