Example for Configuring IS-IS Multi-Instance Processes

This section provides an example for configuring IS-IS multi-instance processes.

Networking Requirements

On IS-IS networks, multiple IS-IS processes need to be used to isolate different access rings. To close the access rings, the IS-IS processes on all access rings need to be enabled. In this case, you need to enable different IGP processes on one interface. This reduces the interface count and configuration workload of the access rings.

As shown in Figure 1:

Device A, Device B, Device C, Device D run IS-IS to implement IP network connectivity and form an IS-IS access ring. In addition, Device A, Device B, Device E, and Device F run IS-IS to implement IP network connectivity and form another IS-IS access ring. IS-IS multi-instance processes are configured on all the devices. Two IS-IS multi-instance processes are enabled on an interface of Device A and Device B, and one IS-IS multi-instance process is enabled on an interface of Device C, Device D, Device E, and Device F.

Figure 1 Networking for configuring IS-IS multi-instance processes

Interfaces 1, 2, and 3 stand for GE 0/1/0, GE 0/1/8, and GE 0/1/16, respectively.



Device Name

Interface Name

IP Address

Device A

GE 0/1/0

10.1.1.2/24

GE 0/1/8

192.168.0.4/24

GE 0/1/16

192.168.1.5/24

Device B

GE 0/1/0

10.1.1.1/24

GE 0/1/8

192.168.0.1/24

GE 0/1/16

192.168.1.1/24

Device C

GE 0/1/0

192.168.2.1/24

GE 0/1/8

192.168.0.2/24

Device D

GE 0/1/0

192.168.2.2/24

GE 0/1/8

192.168.1.2/24

Device E

GE 0/1/0

192.168.2.4/24

GE 0/1/8

192.168.1.4/24

Device F

GE 0/1/0

192.168.2.5/24

GE 0/1/8

192.168.0.3/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IS-IS multi-instance processes on the router devices.

  2. Enable two IS-IS multi-instance processes on an interface of Device A and Device B, and enable one IS-IS multi-instance process on an interface of Device C, Device D, Device E, and Device F.

  3. Configure a cost for each IS-IS multi-instance process on the interface of Device A and Device B.

  4. Check information about IS-IS interfaces.

Data Preparation

To complete the configuration, you need the following data:

  • Area ID of Device A, Device B, Device C, Device D, Device E, and Device F

  • IS-IS multi-instance process IDs of Device A, Device B, Device C, Device D, Device E, and Device F

Procedure

  1. Configure an IP address for each interface. For configuration details, see Configuration Files in this section.
  2. Configure IS-IS multi-instance processes.

    # Configure Device A.

    [~DeviceA] isis 1
    [*DeviceA-isis-1] network-entity 00.1111.1111.1111.00
    [*DeviceA-isis-1] multi-instance enable iid 2
    [*DeviceA-isis-1] commit
    [~DeviceA-isis-1] quit
    [~DeviceA] isis 2
    [*DeviceA-isis-1] network-entity 00.1111.1111.1112.00
    [*DeviceA-isis-2] multi-instance enable iid 3
    [*DeviceA-isis-2] commit
    [~DeviceA-isis-2] quit

    # Configure Device B.

    [~DeviceB] isis 1
    [*DeviceB-isis-1] network-entity 00.2222.2222.2222.00
    [*DeviceB-isis-1] multi-instance enable iid 2
    [*DeviceB-isis-1] commit
    [~DeviceB-isis-1] quit
    [~DeviceB] isis 2
    [*DeviceB-isis-1] network-entity 00.2222.2222.2223.00
    [*DeviceB-isis-2] multi-instance enable iid 3
    [*DeviceB-isis-2] commit
    [~DeviceB-isis-2] quit

    # Configure Device C, Device D, Device E, and Device F.

    Repeat this step for Device C, Device D, Device E, and Device F. For configuration details, see "Configuration Files" in this section.

  3. Configure costs on Device A and Device B.

    # Configure Device A.

    [~DeviceA] interface gigabitethernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] isis enable 1
    [~DeviceA-GigabitEthernet0/1/0] isis enable 2
    [~DeviceA-GigabitEthernet0/1/0] isis process-id 1 cost 5
    [~DeviceA-GigabitEthernet0/1/0] isis process-id 2 cost 15
    [*DeviceA-GigabitEthernet0/1/0] commit
    [~DeviceA-GigabitEthernet0/1/0] quit

    # Configure Device B.

    [~DeviceB] interface gigabitethernet 0/1/0
    [~DeviceB-GigabitEthernet0/1/0] isis enable 1
    [~DeviceB-GigabitEthernet0/1/0] isis enable 2
    [~DeviceB-GigabitEthernet0/1/0] isis process-id 1 cost 5
    [~DeviceB-GigabitEthernet0/1/0] isis process-id 2 cost 15
    [*DeviceB-GigabitEthernet0/1/0] commit
    [~DeviceB-GigabitEthernet0/1/0] quit

  4. Verify the configuration.

    # View information about the specified IS-IS interface on each device. The following example uses the command output on Device A. The command output shows more than one IS-IS process on the interface.

    [~DeviceA] display isis interface gigabitethernet 0/1/0
                Interface information for ISIS(1)
                        ---------------------------------
     Interface    Id      IPV4.State          IPV6.State       MTU  Type  DIS  
     GE0/1/0      001         Up          Mtu:Up/Lnk:Up/IP:Up  1497 L1/L2 No/No
     
                Interface information for ISIS(2)
                        ---------------------------------
    Interface    Id      IPV4.State          IPV6.State        MTU  Type  DIS  
    GE0/1/0      001        Up           Mtu:Up/Lnk:Dn/IP:Dn  1497 L1/L2 No/No

Configuration Files

  • Device A configuration file

    #
    sysname DeviceA
    #
    isis 1
     network-entity 00.1111.1111.1111.00
     multi-instance enable iid 2
    isis 2
     network-entity 00.1111.1111.1112.00
     multi-instance enable iid 3
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
     isis process-id 1 cost 5
     isis enable 2
     isis process-id 2 cost 15
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 192.168.0.4 255.255.255.0
     isis enable 2
    #
    interface GigabitEthernet0/1/16
     undo shutdown
     ip address 192.168.1.5 255.255.255.0
     isis enable 1
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    isis 1
     network-entity 00.2222.2222.2222.00
     multi-instance enable iid 2
    isis 2
     network-entity 00.2222.2222.2223.00
     multi-instance enable iid 3
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     isis process-id 1 cost 5
     isis enable 2
     isis process-id 2 cost 15
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 192.168.0.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/16
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     isis enable 2
    #
    return
  • Device C configuration file

    #
    sysname DeviceC
    #
    isis 2
     network-entity 00.3333.3333.3333.00
     multi-instance enable iid 3
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     isis enable 2
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 192.168.0.2 255.255.255.0
     isis enable 2
    #
    return
  • Device D configuration file

    #
    sysname DeviceD
    #
    isis 2
     network-entity 00.4444.4444.4444.00
     multi-instance enable iid 3
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     isis enable 2
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     isis enable 2
    #
    return
  • Device E configuration file

    #
    sysname DeviceE
    #
    isis 1
     network-entity 00.5555.5555.5555.00
     multi-instance enable iid 2
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.2.4 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 192.168.1.4 255.255.255.0
     isis enable 1
    #
    return
  • Device F configuration file

    #
    sysname DeviceF
    #
    isis 1
     network-entity 00.6666.6666.6666.00
     multi-instance enable iid 2
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 192.168.2.5 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/1/8
     undo shutdown
     ip address 192.168.0.3 255.255.255.0
     isis enable 1
    #
    return
Copyright © Huawei Technologies Co., Ltd.
Copyright © Huawei Technologies Co., Ltd.
< Previous topic Next topic >